SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Device (Printer)  >   JetDirect Vendors:   HPE
JetDirect FTP Bug Lets Remote Users Deny Service
SecurityTracker Alert ID:  1017532
SecurityTracker URL:  http://securitytracker.com/id/1017532
CVE Reference:   CVE-2007-1772   (Links to External Site)
Updated:  May 3 2007
Original Entry Date:  Jan 18 2007
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): firmware x.20.nn up to and including x.24.nn
Description:   A vulnerability was reported in JetDirect. A remote user can cause denial of service conditions.

A remote user can open a passive FTP connection and send a RERT command with a specially crafted pathname value to cause the target engine to crash.

A demonstration exploit was provided [using python]:

python /usr/lib/python2.4/ftplib.py -d [target] -l -p `python -c 'print "A"*300'`

Handrix from MorX security research team reported the details of this vulnerability.

Impact:   A remote user can cause the target engine to crash.
Solution:   HP has issued a fix.

For J4169A 610n - upgrade the firmware to version L.25.nn or greater.

For J6057A 615n - upgrade the firmware to version R.25.nn or greater.

Instructions for upgrading Jetdirect firmware are available at:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=bpj07429

The HP advisory is available at:

http://www2.itrc.hp.com/service/cki/docDisplay.do?docId=c00838612

Vendor URL:  www2.itrc.hp.com/service/cki/docDisplay.do?docId=c00838612 (Links to External Site)
Cause:   Not specified

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC