SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   wget Vendors:   GNU [multiple authors]
wget FTP SYST Response Buffer Overflow Lets Remote Users Deny Service
SecurityTracker Alert ID:  1017516
SecurityTracker URL:  http://securitytracker.com/id/1017516
CVE Reference:   CVE-2006-6719   (Links to External Site)
Date:  Jan 16 2007
Impact:   Denial of service via network
Exploit Included:  Yes  
Version(s): 1.10.2
Description:   A vulnerability was reported in wget. A remote user can cause denial of service conditions.

A remote FTP server can send specially crafted (blank) 220 responses to a SYST command from the target application to cause the target application to crash.

The vulnerability resides in the ftp_syst() function in 'ftp-basic.c'.

A demonstration exploit is available at:

http://www.milw0rm.com/exploits/2947

Federico L. Bossi Bonin reported this vulnerability.

Impact:   A remote server can cause denial of service conditions.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.gnu.org/software/wget/wget.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC