SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Red Hat JBoss Vendors:   JBoss Group
(Red Hat Issues Fix) JBoss Application Server Error in DeploymentFileRepository Class Lets Remote Users Read and Write Files
SecurityTracker Alert ID:  1017290
SecurityTracker URL:  http://securitytracker.com/id/1017290
CVE Reference:   CVE-2006-5750   (Links to External Site)
Date:  Nov 27 2006
Impact:   Disclosure of system information, Disclosure of user information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in JBoss Application Server. A remote user can view or write files on the target system.

The setBaseDir() method of the DeploymentFileRepository class does not properly validate the basedir setting. A remote user can connect to the console manager to read or write arbitrary files on target system with the privileges of the JBoss user account.

Symantec reported this vulnerability to the vendor.

The original bug report is available at:

http://jira.jboss.com/jira/browse/JBAS-3861

Impact:   A remote user can view or write files on the target system.
Solution:   Red Hat has released a fix.

Red Hat Application Stack v1 for Enterprise Linux AS (v.4):

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/RHWAS/SRPMS/jbossas-4.0.4-1.el4s1.25.src.rpm
ddcee54695279bfa2bcc1e6dc272edc5 jbossas-4.0.4-1.el4s1.25.src.rpm

noarch:
edf562a2624881d8198f23bd3e61f443 jbossas-4.0.4-1.el4s1.25.noarch.rpm

Red Hat Application Stack v1 for Enterprise Linux ES (v.4):

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/RHWAS/SRPMS/jbossas-4.0.4-1.el4s1.25.src.rpm
ddcee54695279bfa2bcc1e6dc272edc5 jbossas-4.0.4-1.el4s1.25.src.rpm

noarch:
edf562a2624881d8198f23bd3e61f443 jbossas-4.0.4-1.el4s1.25.noarch.rpm

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2006-0743.html

Vendor URL:  www.jboss.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  4

Message History:   This archive entry is a follow-up to the message listed below.
Nov 27 2006 JBoss Application Server Error in DeploymentFileRepository Class Lets Remote Users Read and Write Files



 Source Message Contents

Subject:  [RHSA-2006:0743-01] Critical: jbossas security update


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Critical: jbossas security update
Advisory ID:       RHSA-2006:0743-01
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2006-0743.html
Issue date:        2006-11-27
Updated on:        2006-11-27
Product:           Red Hat Application Stack
CVE Names:         CVE-2006-5750 
- ---------------------------------------------------------------------

1. Summary:

An updated jbossas package that corrects a security vulnerability is now
available for Red Hat Application Stack.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Application Stack v1 for Enterprise Linux AS (v.4) - noarch
Red Hat Application Stack v1 for Enterprise Linux ES (v.4) - noarch

3. Problem description:

JBoss Application Server is a J2EE certified platform for developing and
deploying enterprise Java applications, Web applications, and Portals.

Symantec discovered a flaw in the DeploymentFileRepository class of the
JBoss Application Server. A remote attacker who is able to access the
console manager could read or write to files with the permissions of the
JBoss user. This could potentially lead to arbitrary code execution as the
jboss user. (CVE-2006-5750)

For the Red Hat Application Stack, the jbossas service is not enabled by
default. Once the jbossas service is enabled, the console manager will
become accessible on port 8080. Although port 8080 will be blocked from
outside access by the default Red Hat Enterprise Linux firewall rules,
users should ensure that the console is not available publicly and is
adequately protected by authentication as explained in the JBoss
documentation. A correct configuration of the JBoss Application Server
would mitigate this vulnerability to only being exploitable by users who
have authorization to use the console manager.

All users of Red Hat Application Stack are advised to upgrade to these
updated packages, which resolve the directory traversal issue with a
backported patch.

These updated packages also contain a change to the default jbossas
configuration file.  For users installing Red Hat Application Stack for the
first time, all JBoss Application Server network services, including the
management consoles, will be restricted by default to localhost.  No change
is made for users upgrading previously installed jbossas packages.  

Users who already have Red Hat Application Stack installed should check to
make sure that they have correctly followed the security guidelines and
that the management consoles are not accessible to unauthorized users.  

Red Hat would like to thank Symantec for reporting this issue.

4. Solution:

Before applying this update, make sure that the jbossas service is not
running and all previously released errata relevant to your system have
been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains
the desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

215828 - CVE-2006-5750 JBoss Java Class DeploymentFileRepository Directory Traversal
216177 - JBossAS needs to be bound to localhost by default
216786 - Config files in the jbossas rpm should be marked accordingly

6. RPMs required:

Red Hat Application Stack v1 for Enterprise Linux AS (v.4):

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/RHWAS/SRPMS/jbossas-4.0.4-1.el4s1.25.src.rpm
ddcee54695279bfa2bcc1e6dc272edc5  jbossas-4.0.4-1.el4s1.25.src.rpm

noarch:
edf562a2624881d8198f23bd3e61f443  jbossas-4.0.4-1.el4s1.25.noarch.rpm

Red Hat Application Stack v1 for Enterprise Linux ES (v.4):

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/RHWAS/SRPMS/jbossas-4.0.4-1.el4s1.25.src.rpm
ddcee54695279bfa2bcc1e6dc272edc5  jbossas-4.0.4-1.el4s1.25.src.rpm

noarch:
edf562a2624881d8198f23bd3e61f443  jbossas-4.0.4-1.el4s1.25.noarch.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5750
http://kbase.redhat.com/faq/FAQ_107_9629.shtm
http://www.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2006 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFFawj3XlSAg2UNWIIRAu8iAJ48kGq7URffk+k7rgIL/b7FQwZMgQCgmqpK
gWZTVStlhcX/y9wPZzOodtQ=
=pyX9
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC