SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Oracle WebLogic Vendors:   BEA Systems
WebLogic JSP Compilation Error May Allow Remote Users to View JSP Source Code
SecurityTracker Alert ID:  1016100
SecurityTracker URL:  http://securitytracker.com/id/1016100
CVE Reference:   CVE-2006-2466   (Links to External Site)
Updated:  Oct 31 2009
Original Entry Date:  May 15 2006
Impact:   Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.0 SP6, 8.1 SP4; and prior service packs
Description:   A vulnerability was reported in WebLogic Server and WebLogic Express. A remote user may be able to view JSP source code.

A timing condition related to JSP code with compilation errors may allow a remote user to view the source code.

Impact:   A remote user may be able to view JSP source code.
Solution:   The vendor has provided the following solution [quoted]:

WebLogic Server and WebLogic Express version 8.1

* Upgrade to service pack 5.

WebLogic Server and WebLogic Express version 7.0

* Upgrade to service pack 7.

The vendor's advisory is available at:

http://dev2dev.bea.com/pub/advisory/192

Vendor URL:  dev2dev.bea.com/pub/advisory/192 (Links to External Site)
Cause:   Access control error, Exception handling error
Underlying OS:  Linux (Red Hat Enterprise), Linux (SuSE), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (NT), Windows (2000), Windows (2003)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC