SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   KOffice Vendors:   KDE.org
(Red Hat Issues Revised Fix) KDE KOffice kpdf Buffer Overflows in Processing DCT and JPX Streams May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1015745
SecurityTracker URL:  http://securitytracker.com/id/1015745
CVE Reference:   CVE-2005-3191, CVE-2005-3192, CVE-2005-3193, CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, CVE-2005-3627, CVE-2006-0746   (Links to External Site)
Date:  Mar 10 2006
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): KOffice 1.3.0 up to including KOffice 1.4.2
Description:   Several vulnerabilities were reported in KDE KOffice in the kpdf component. A remote user can cause arbitrary code to be executed on the target user's system.

The DCT stream parsing code does not properly validate user-supplied input. The DCTStream::readBaselineSOF() function in 'Stream.cc' does not properly validate the 'numComps' parameter. A remote user can create a specially crafted PDF file that, when processed by the target user, will trigger an overflow at potentially execute arbitrary code.

The DCTStream::readProgressiveSOF() and StreamPredictor::StreamPredictor() functions are also affected.

A similar overflow exists in the JPX Stream parsing code used in decoding embedded JPEG 2000 images. The JPXStream::readCodestream() function in 'JPXStream.cc' does not properly validate the 'nXTiles' and 'nYTiles' parameters.

The vulnerability resides in xpdf code that is shared with kpdf. The vulnerabilities in xpdf were originally reported by iDEFENSE.

In January 2006, the vendor issued an update to the advisory indicating that the original patches were incomplete and have been retracted.

In March 2006, it was reported that the fix for CVE-2005-3627 was not complete. The resulting vulnerability was assigned CVE-2006-0746. Marcelo Ricardo Leitner discovered this vulnerability.

Impact:   A remote user can create a PDF file that, when processed by the target user, will execute arbitrary code on the target user's system with the privileges of the target user.
Solution:   Red Hat has released a revised fix.

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598 kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712 kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875 kdegraphics-devel-3.3.1-3.9.ia64.rpm

ppc:
e29d12dc045af9bba805a60c8348f839 kdegraphics-3.3.1-3.9.ppc.rpm
b9ea1232be57e9a1cd16816f1ff23dc1 kdegraphics-devel-3.3.1-3.9.ppc.rpm

s390:
e4dd3d1e48c4c5cb1ef8c4176ce63af5 kdegraphics-3.3.1-3.9.s390.rpm
6eea4a51102edc69754260551e973550 kdegraphics-devel-3.3.1-3.9.s390.rpm

s390x:
efa16030f3945a7665559183d4fbb2c2 kdegraphics-3.3.1-3.9.s390x.rpm
04e7d043636a7df2fe69c19f2f57ee99 kdegraphics-devel-3.3.1-3.9.s390x.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8 kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598 kdegraphics-devel-3.3.1-3.9.i386.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8 kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598 kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712 kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875 kdegraphics-devel-3.3.1-3.9.ia64.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8 kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598 kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712 kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875 kdegraphics-devel-3.3.1-3.9.ia64.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8 kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c kdegraphics-devel-3.3.1-3.9.x86_64.rpm

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2006-0262.html

This advisory replaces advisory RHSA-2005:868.

Vendor URL:  www.kde.org/info/security/advisory-20051207-2.txt (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Red Hat Enterprise)
Underlying OS Comments:  4

Message History:   This archive entry is a follow-up to the message listed below.
Dec 7 2005 KDE KOffice kpdf Buffer Overflows in Processing DCT and JPX Streams May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [RHSA-2006:0262-01] Important: kdegraphics security update


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Important: kdegraphics security update
Advisory ID:       RHSA-2006:0262-01
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2006-0262.html
Issue date:        2006-03-09
Updated on:        2006-03-09
Product:           Red Hat Enterprise Linux
Obsoletes:         RHSA-2005:868
CVE Names:         CVE-2006-0746
- ---------------------------------------------------------------------

1. Summary:

Updated kdegraphics packages that fully resolve a security issue in kpdf
are now available.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

The kdegraphics packages contain applications for the K Desktop Environment
including kpdf, a PDF file viewer.

Marcelo Ricardo Leitner discovered that a kpdf security fix, CVE-2005-3627,
was incomplete.  Red Hat issued kdegraphics packages with this incomplete
fix in RHSA-2005:868.  An attacker could construct a carefully crafted PDF
file that could cause kpdf to crash or possibly execute arbitrary code when
opened.  The Common Vulnerabilities and Exposures project assigned the name
CVE-2006-0746 to this issue.

Users of kpdf should upgrade to these updated packages, which contain a
backported patch to resolve this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

184307 - CVE-2006-0746 kpdf buffer overflow


6. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b  kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f  kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598  kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712  kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875  kdegraphics-devel-3.3.1-3.9.ia64.rpm

ppc:
e29d12dc045af9bba805a60c8348f839  kdegraphics-3.3.1-3.9.ppc.rpm
b9ea1232be57e9a1cd16816f1ff23dc1  kdegraphics-devel-3.3.1-3.9.ppc.rpm

s390:
e4dd3d1e48c4c5cb1ef8c4176ce63af5  kdegraphics-3.3.1-3.9.s390.rpm
6eea4a51102edc69754260551e973550  kdegraphics-devel-3.3.1-3.9.s390.rpm

s390x:
efa16030f3945a7665559183d4fbb2c2  kdegraphics-3.3.1-3.9.s390x.rpm
04e7d043636a7df2fe69c19f2f57ee99  kdegraphics-devel-3.3.1-3.9.s390x.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8  kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c  kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b  kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f  kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598  kdegraphics-devel-3.3.1-3.9.i386.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8  kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c  kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b  kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f  kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598  kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712  kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875  kdegraphics-devel-3.3.1-3.9.ia64.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8  kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c  kdegraphics-devel-3.3.1-3.9.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/kdegraphics-3.3.1-3.9.src.rpm
2122c40615954e8afc7f52a6f630885b  kdegraphics-3.3.1-3.9.src.rpm

i386:
61262d041570015941825522d4c52d6f  kdegraphics-3.3.1-3.9.i386.rpm
99a093aef5554bcb04ebd288938b8598  kdegraphics-devel-3.3.1-3.9.i386.rpm

ia64:
e79b5a98bbceedf04652037eaf08b712  kdegraphics-3.3.1-3.9.ia64.rpm
0ac83c2dc0edfaed4049975bcdde8875  kdegraphics-devel-3.3.1-3.9.ia64.rpm

x86_64:
9efeda23490049fea1957f07c340d9c8  kdegraphics-3.3.1-3.9.x86_64.rpm
c74d43b414e511e26e8b8d5f78e3cf0c  kdegraphics-devel-3.3.1-3.9.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3627
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0746

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2006 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFEEJaPXlSAg2UNWIIRAoWrAJ0ciVNjApRR5Gnkt2neqbxcOhfpHACdG824
7D01fgwwEWK+Y6p2kYF/67w=
=yq8S
-----END PGP SIGNATURE-----


-- 
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC