SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   NFuse Vendors:   Citrix
Citrix NFuse Elite Input Validation Flaw in Login Pages Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1015305
SecurityTracker URL:  http://securitytracker.com/id/1015305
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Dec 2 2005
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0
Description:   A vulnerability was reported in Citrix NFuse Elite. A remote user can conduct cross-site scripting attacks.

The login pages of Citrix NFuse Elite do not properly filter HTML code from user-supplied input in the user name field. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the MetaFrame software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Citrix NFuse software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor indicates that users of Citrix NFuse Elite 1.0 can contact their normal Citrix support representative to obtain guidance on mitigating this vulnerability.

The vendor's advisory is available at:

http://support.citrix.com/article/CTX108208

Vendor URL:  support.citrix.com/article/CTX108208 (Links to External Site)
Cause:   Input validation error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC