SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   ATutor Vendors:   ATRC
ATutor Input Validation Hole in 'registration.php' Lets Remote Users Inject SQL Commands and Execute Arbitrary Code
SecurityTracker Alert ID:  1015166
SecurityTracker URL:  http://securitytracker.com/id/1015166
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Nov 8 2005
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.5.1pl2
Description:   rgod reported a vulnerability in ATutor. A remote user can inject SQL commands and arbitrary operating system commands on the target system.

The 'registration.php' script does not properly validate user-supplied input. If magic_quotes_gpc is disabled, a remote user can supply a specially crafted e-mail address value that ends in a NULL character to execute SQL commands on the underlying database.

A remote user can exploit this to execute arbitrary commands on the target system.

The original advisory is available at:

http://rgod.altervista.org/atutor151pl2.html

Impact:   A remote user can execute SQL commands on the underlying database, including the execution of arbitrary operating system commands on the target system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  www.atutor.ca/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  ATutor <= 1.5.1pl2 SQL Injection / Remote commands execution

http://rgod.altervista.org/atutor151pl2.html

rgod
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC