SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Turquoise SuperStat Vendors:   Karlsson, Peter
Turquoise SuperStat Buffer Overflow May Let Remote Servers Execute Arbitrary Code
SecurityTracker Alert ID:  1014915
SecurityTracker URL:  http://securitytracker.com/id/1014915
CVE Reference:   CVE-2005-2658   (Links to External Site)
Date:  Sep 16 2005
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.2.4
Description:   A vulnerability was reported in Turquoise SuperStat (turqstat). A remote server may be able to cause arbitrary code to be executed on the target system.

A remote NNTP server can supply a specially crafted string to trigger a buffer overflow on the target system and potentially execute arbitrary code.

The vulnerability resides in 'utility.cpp' in the processing of date information.

The vendor (Peter Karlsson) discovered this vulnerability.

Impact:   A remote NNTP server may be able to cause arbitrary code to be executed on the target system.
Solution:   The vendor has released a fixed version (2.2.4), available at:

http://www.softwolves.pp.se/sw/software/turquoise

Debian has issued a fix for Debian GNU/Linux:

http://www.debian.org/security/2005/dsa-812

Vendor URL:  www.softwolves.pp.se/sw/software/turquoise (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC