SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Zlib Vendors:   GNU [multiple authors]
(OpenBSD Issues Fix) Zlib Buffer Overflow in inflate_table() May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1014425
SecurityTracker URL:  http://securitytracker.com/id/1014425
CVE Reference:   CVE-2005-2096   (Links to External Site)
Date:  Jul 8 2005
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.2.2
Description:   A buffer overflow was reported in zlib in the processing of compressed data streams. A remote user may be able to cause denial of service conditions or execute arbitrary code on the target system.

A user can create a specially crafted compressed data stream that, when processed by an application using zlib, will trigger an overflow in the inflate_table() function and cause the application to crash or execute arbitrary code.

The vulnerability resides in 'inftrees.c'.

Tavis Ormandy of the Gentoo Linux Security Audit Team discovered this vulnerability.

Impact:   A user can cause an application using zlib to crash or execute arbitrary code. The specific impact depends on the application.
Solution:   OpenBSD has released a fix.

For 3.6:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.6/common/019_libz.patch

For 3.7:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.7/common/004_libz.patch

Vendor URL:  www.zlib.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  UNIX (OpenBSD)
Underlying OS Comments:  3.6, 3.7

Message History:   This archive entry is a follow-up to the message listed below.
Jul 6 2005 Zlib Buffer Overflow in inflate_table() May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  Buffer overflow in zlib


Insufficient checking in the zlib compression library (installed
as libz on OpenBSD) can result in a buffer overflow and a program
crash.  It is not known at this time whether maliciously-crafted
compressed files can be used to execute arbitrary code.

Since zlib is in wide use throughout the base OS, as well as in
ports, users are advised to patch their systems as soon as possible.

A fix has been committed to OpenBSD-current as well as the 3.6 and
3.7 -stable branches.  Patches are also available for OpenBSD 3.6
and 3.7.  OpenBSD versions 3.4 and lower are not affected as they
use an older version of zlib that does not contain the vulnerable
code.

3.6 patch:  
    ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.6/common/019_libz.patch
3.7 patch:
    ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.7/common/004_libz.patch

The 3.6 patch also applies to OpenBSD 3.5.

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC