SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Image Cropper/Resizer Vendors:   CityPost
CityPost Image Cropper/Resizer Input Validation Hole Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1013751
SecurityTracker URL:  http://securitytracker.com/id/1013751
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Apr 18 2005
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Exploit Included:  Yes  
Version(s): 52
Description:   sNKenjoi reported an input validation vulnerability in CityPost's Image Cropper/Resizer. A remote user can conduct cross-site scripting attacks.

The 'image-editor-52' script does not properly validate user-supplied input in several varaibles. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Image Cropper/Resizer software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

http://[target]/image-editor-52/?m1=[XSS]&m2=[XSS]&m3=[XSS]&imgsrc=[XSS]&m4=[XSS]

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Image Cropper/Resizer software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   No solution was available at the time of this entry.
Vendor URL:  tech.citypost.ca/image-editor-52.php (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  sNKenjoi's Security Advisory: XSS Vunerabilities in Multiple CityPost Software


sNKenjoi's Security Advisory: XSS Vunerabilities in Multiple CityPost Software


Security Advisory: XSS Vunerabilities in Multiple CityPost Software
Severity: Medium
Title: XSS Vunerabilities in Simple PHP Upload, Simple Image Editor
and Automated Link Exchange


Vendor: Allen Kim
Vendor Website: http://tech.citypost.ca/

Proof of Concept Exploits: 

Simple PHP Upload - XSS
http://localhost/simple-upload-53.php?message=[XSS]

Simple Image Editor - XSS's in 5 seperate places
http://localhost/image-editor-52/?m1=[XSS]&m2=[XSS]&m3=[XSS]&imgsrc=[XSS]&m4=[XSS]

Automated Link Exchange - XSS
http://localhost/lnkx/message.php?msg=[XSS]

snkenjoi.com & zone-h.org
snkenjoi@gmail.com
-- snkenjoi.com 
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC