SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   McAfee NetShield Vendors:   McAfee
McAfee NetShield Buffer Overflow in Processing LHA Headers Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1013467
SecurityTracker URL:  http://securitytracker.com/id/1013467
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Mar 18 2005
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): library versions prior to 4400
Description:   A vulnerability was reported in McAfee NetShield in the processing of LHA archives. A remote user can execute arbitrary code with System privileges.

The underlying McAfee Antivirus Library does not properly parse LHA files. Type 2 header file name fields are not properly validated to ensure that the user-supplied value can fit within the allocated memory before the value is copied to memory. A value between 0x130 and 0x167 bytes in length can trigger a buffer overflow.

A remote user can send a specially crafted LHA file to the target system to trigger the buffer overflow and execute arbitrary code with System level privileges.

The original advisory is available at:

http://xforce.iss.net/xforce/alerts/id/190

Alex Wheeler of ISS X-Force discovered this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system with System level privileges.
Solution:   The vendor has issued a fixed library version (4400).
Vendor URL:  www.mcafee.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Windows (NT), Windows (2000)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC