SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Instant Messaging/IRC/Chat)  >   Gaim Vendors:   Gaim.sourceforge.net
(Gentoo Issues Fix) Gaim HTML Processing Error Lets Remote Users Crash the Client
SecurityTracker Alert ID:  1013346
SecurityTracker URL:  http://securitytracker.com/id/1013346
CVE Reference:   CVE-2005-0473   (Links to External Site)
Updated:  Mar 2 2005
Original Entry Date:  Mar 2 2005
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.1.3
Description:   A vulnerability was reported in Gaim in the processing of HTML code. A remote user can cause denial of service conditions.

A remote user can send specially crafted HTML to trigger an invalid memory access and cause the target Gaim client to crash.

Impact:   A remote user can cause the target user's Gaim client to crash.
Solution:   Gentoo has released a fix and indicates that all Gaim users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/gaim-1.1.4"

Vendor URL:  gaim.sourceforge.net/security/?id=11 (Links to External Site)
Cause:   Exception handling error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Feb 18 2005 Gaim HTML Processing Error Lets Remote Users Crash the Client



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200503-03 ] Gaim: Multiple Denial of Service issues


--nextPart2020864.VLbntRKLQD
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200503-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Gaim: Multiple Denial of Service issues
      Date: March 01, 2005
      Bugs: #83253
        ID: 200503-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Gaim which could allow a
remote attacker to crash the application.

Background
==========

Gaim is a full featured instant messaging client which handles a
variety of instant messaging protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  net-im/gaim       < 1.1.4                                >= 1.1.4

Description
===========

Specially crafted SNAC packets sent by other instant-messaging users
can cause Gaim to loop endlessly (CAN-2005-0472). Malformed HTML code
could lead to invalid memory accesses (CAN-2005-0208 and
CAN-2005-0473).

Impact
======

Remote attackers could exploit these issues, resulting in a Denial of
Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gaim users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/gaim-1.1.4"

References
==========

  [ 1 ] CAN-2005-0208
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0208
  [ 2 ] CAN-2005-0472
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0472
  [ 3 ] CAN-2005-0473
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0473

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200503-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart2020864.VLbntRKLQD
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBCJMdKzKC5hMHO6rkRArdAAKCGxTJ7GxFs/aLlQW0NBuT9/AC7HQCfV4x+
Y+xQkK1GctTZ2G5VH9KeeHA=
=dGRc
-----END PGP SIGNATURE-----

--nextPart2020864.VLbntRKLQD--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC