SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   MediaWiki Vendors:   wikipedia.sourceforge.net
(Gentoo Issues Fix) MediaWiki Input Validation Holes Permit Cross-Site Scripting Attacks and Directory Traversal Flaw Lets Remote Authenticated Administrators Delete Files
SecurityTracker Alert ID:  1013330
SecurityTracker URL:  http://securitytracker.com/id/1013330
CVE Reference:   CVE-2005-0534, CVE-2005-0535, CVE-2005-0536   (Links to External Site)
Date:  Mar 1 2005
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.3.11
Description:   Several vulnerabilities were reported in MediaWiki. A remote user can conduct cross-site scripting attacks. A remote authenticated administrator can delete certain files on the system.

The software does not properly validate user-supplied input in various fields. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the MediaWiki software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The software does not properly validate user-supplied input in the image deletion function. A remote authenticated administrator can delete arbitrary files in directories that are writable by the web server process. For directories or files that are not writable by the web server, a remote authenticated administrator can determine if the specified file exists.

The vendor discovered these vulnerabilities as part of a security audit.

The vendor reported these vulnerabilities.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the MediaWiki software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A remote authenticated administrator can delete files with the privileges of the web server process.

Solution:   Gentoo has released a fix and indicates that all MediaWiki users should upgrade to the latest available version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.3.11"

Vendor URL:  wikipedia.sourceforge.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Feb 22 2005 MediaWiki Input Validation Holes Permit Cross-Site Scripting Attacks and Directory Traversal Flaw Lets Remote Authenticated Administrators Delete Files



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200502-33 ] MediaWiki: Multiple vulnerabilities


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig454A8A12F39CCA252B43CB8A
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: MediaWiki: Multiple vulnerabilities
      Date: February 28, 2005
      Bugs: #80729, #82954
        ID: 200502-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

MediaWiki is vulnerable to cross-site scripting, data manipulation and
security bypass attacks.

Background
==========

MediaWiki is a collaborative editing software, used by big projects
like Wikipedia.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/mediawiki      < 1.3.11                        >= 1.3.11

Description
===========

A security audit of the MediaWiki project discovered that MediaWiki is
vulnerable to several cross-site scripting and cross-site request
forgery attacks, and that the image deletion code does not sufficiently
sanitize input parameters.

Impact
======

By tricking a user to load a carefully crafted URL, a remote attacker
could hijack sessions and authentication cookies to inject malicious
script code that will be executed in a user's browser session in
context of the vulnerable site, or use JavaScript submitted forms to
perform restricted actions. Using the image deletion flaw, it is also
possible for authenticated administrators to delete arbitrary files via
directory traversal.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MediaWiki users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.3.11"

References
==========

  [ 1 ] Secunia Advisory SA14125
        http://secunia.com/advisories/14125/
  [ 2 ] CAN-2005-0534
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0534
  [ 3 ] CAN-2005-0535
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0535
  [ 4 ] CAN-2005-0536
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0536

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-33.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enig454A8A12F39CCA252B43CB8A
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCI4VIvcL1obalX08RAq0fAJ48LRQzKUW+GBHKP4Wdzio5a+eRLQCgpQCs
Ana0IzmAh8DGyi53/wuPcjc=
=KlHD
-----END PGP SIGNATURE-----

--------------enig454A8A12F39CCA252B43CB8A--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC