SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   Cyrus IMAP Server Vendors:   Carnegie Mellon University
(Gentoo Issues Fix) Cyrus IMAPd Buffer Overflows in Annotate Extension, Cached Header, and Fetchnews May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1013281
SecurityTracker URL:  http://securitytracker.com/id/1013281
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Feb 24 2005
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.2.11
Description:   Some buffer overflow vulnerabilities were reported in Cyrus IMAPd. A remote authenticated user may be able to execute arbitrary code.

There are some single byte buffer overflows in the imap annotate extension functions and in the processing of cached headers. A remote authenticated user can invoke these functions to trigger the buffer overflow.

There is also a buffer overflow in the fetchnews function. A news administrator on a peer news system can trigger this buffer overflow.

Sean Larsson is credited with reporting these flaws.

Impact:   A remote authenticated user may be able to execute arbitrary code on the target system with the privileges of the imap service.
Solution:   Gentoo has released a fix and indicates that all Cyrus IMAP Server users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-mail/cyrus-imapd-2.2.12"

Vendor URL:  asg.web.cmu.edu/cyrus/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Feb 24 2005 Cyrus IMAPd Buffer Overflows in Annotate Extension, Cached Header, and Fetchnews May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200502-29 ] Cyrus IMAP Server: Multiple overflow vulnerabilities



--wac7ysb48OaltWcw
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Cyrus IMAP Server: Multiple overflow vulnerabilities
      Date: February 23, 2005
      Bugs: #82404
        ID: 200502-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Cyrus IMAP Server is affected by several overflow vulnerabilities
which could potentially lead to the remote execution of arbitrary
code.

Background
==========

The Cyrus IMAP Server is an efficient, highly-scalable IMAP e-mail
server.

Affected packages
=================

    -------------------------------------------------------------------
     Package               /  Vulnerable  /                 Unaffected
    -------------------------------------------------------------------
  1  net-mail/cyrus-imapd      < 2.2.12                      >= 2.2.12

Description
===========

Possible single byte overflows have been found in the imapd annotate
extension and mailbox handling code. Furthermore stack buffer overflows
have been found in fetchnews, the backend and imapd.

Impact
======

An attacker, who could be an authenticated user or an admin of a
peering news server, could exploit these vulnerabilities to execute
arbitrary code with the rights of the user running the Cyrus IMAP
Server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Cyrus IMAP Server users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-mail/cyrus-imapd-2.2.12"

References
==========

  [ 1 ] Cyrus IMAP Announcement
        http://asg.web.cmu.edu/archive/message.php?mailbox=archive.info-cyrus&msg=33723

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--wac7ysb48OaltWcw
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFCHL7ZGc/RGrFqUYMRApUAAJ9qnhcPZAk2yzW429xiFhE3aeLz1QCcD9hv
L3Sun/qSaajZYR/56mM/xeg=
=nn6n
-----END PGP SIGNATURE-----

--wac7ysb48OaltWcw--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC