SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   wpa_supplicant Vendors:   Malinen, Jouni et al
(Gentoo Issues Fix) wpa_supplicant Key Data Length Missing Validation Lets Remote Users Crash the Service
SecurityTracker Alert ID:  1013227
SecurityTracker URL:  http://securitytracker.com/id/1013227
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Feb 17 2005
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 0.2.7 and 0.3.8
Description:   A vulnerability was reported in wpa_supplicant in the processing of WPA2 frames. A remote user can cause denial of service conditions.

The software does not properly validate the Key Data Length in received EAPOL-Key frames. A remote user can send a specially crafted packet to trigger a buffer overflow and cause wpa_supplicant to crash.

If WPA2 is enabled, a remote user can send a specially crafted EAPOL-Key frame (message 1 of 4-Way Handshake) to trigger the buffer overflow. If WPA2 is not enabled, a remote authenticated user can send specially crafted frames (message 3 of 4-Way Handshake) to trigger the overflow.

The vulnerability resides in 'wpa.c'.

Impact:   A remote user can cause the target service to crash.
Solution:   Gentoo has released a fix and indicates that all wpa_supplicant users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/wpa_supplicant-0.2.7"

Vendor URL:  hostap.epitest.fi/wpa_supplicant/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Feb 17 2005 wpa_supplicant Key Data Length Missing Validation Lets Remote Users Crash the Service



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200502-22 ] wpa_supplicant: Buffer overflow vulnerability



--EeQfGwPcQSOJBaQU
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: wpa_supplicant: Buffer overflow vulnerability
      Date: February 16, 2005
      Bugs: #81993
        ID: 200502-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

wpa_supplicant contains a buffer overflow that could lead to a Denial
of Service.

Background
==========

wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
802.11i / RSN).

Affected packages
=================

    -------------------------------------------------------------------
     Package                      /  Vulnerable  /          Unaffected
    -------------------------------------------------------------------
  1  net-wireless/wpa_supplicant       < 0.2.7                >= 0.2.7

Description
===========

wpa_supplicant contains a possible buffer overflow due to the lacking
validation of received EAPOL-Key frames.

Impact
======

An attacker could cause the crash of wpa_supplicant using a specially
crafted packet.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All wpa_supplicant users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-wireless/wpa_supplicant-0.2.7"

References
==========

  [ 1 ] wpa_supplicant Announcement
        http://lists.shmoo.com/pipermail/hostap/2005-February/009465.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-22.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--EeQfGwPcQSOJBaQU
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFCE53GGc/RGrFqUYMRAqF8AJwPO/01Z7c+UJmiOKRAJotimPLC5gCfbmpH
QCec4yvaI3wJ+b5FbbPTweY=
=cHOc
-----END PGP SIGNATURE-----

--EeQfGwPcQSOJBaQU--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC