SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   Mailman Vendors:   GNU [multiple authors]
(Mandrake Issues Fix) Mailman Input Validation Hole in 'private.py' Discloses Files to Remote Users
SecurityTracker Alert ID:  1013213
SecurityTracker URL:  http://securitytracker.com/id/1013213
CVE Reference:   CVE-2005-0202   (Links to External Site)
Date:  Feb 16 2005
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.1 - 2.1.5
Description:   An input validation vulnerability was reported in Mailman in 'private.py'. A remote user can access arbitrary files on the target system.

The true_path() function does not properly validate user-supplied input. A remote user that is a member of a private mailman list can submit a specially crafted input value to access files on the system, including the mailman configuration files and passwords.

A demonsration exploit may contain the following string:

"/...../"

Marcus Meissner reported this flaw.

Impact:   A remote user can access arbitrary files on the target system, including the mailman configuration files with user e-mail addresses and passwords.
Solution:   Mandrake has released a fix.

Mandrakelinux 10.0:
2962bcf8974ad0f4f0e47fa957a8a276 10.0/RPMS/mailman-2.1.4-2.3.100mdk.i586.rpm
6e1afd0483efcc74c780dd2a7533263a 10.0/SRPMS/mailman-2.1.4-2.3.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
7b2ba12c273fd6f39b2a98a533fe1029 amd64/10.0/RPMS/mailman-2.1.4-2.3.100mdk.amd64.rpm
6e1afd0483efcc74c780dd2a7533263a amd64/10.0/SRPMS/mailman-2.1.4-2.3.100mdk.src.rpm

Mandrakelinux 10.1:
d2382f8a1d35bbf90ac29729d67f5508 10.1/RPMS/mailman-2.1.5-7.3.101mdk.i586.rpm
d2382f8a1d35bbf90ac29729d67f5508 10.1/SRPMS/mailman-2.1.5-7.3.101mdk.i586.rpm

Mandrakelinux 10.1/X86_64:
d4e2e15b0e16b4cb4db4e31c01ea71a9 x86_64/10.1/RPMS/mailman-2.1.5-7.3.101mdk.x86_64.rpm
d2382f8a1d35bbf90ac29729d67f5508 x86_64/10.1/SRPMS/mailman-2.1.5-7.3.101mdk.i586.rpm

Corporate Server 2.1:
eb01c4300056aec9ed25b79906ba564a corporate/2.1/RPMS/mailman-2.0.14-1.3.C21mdk.i586.rpm
f5bdc329649f114e49d8346406a34957 corporate/2.1/SRPMS/mailman-2.0.14-1.3.C21mdk.src.rpm

Corporate Server 2.1/X86_64:
eb01c4300056aec9ed25b79906ba564a x86_64/corporate/2.1/RPMS/mailman-2.0.14-1.3.C21mdk.i586.rpm
f5bdc329649f114e49d8346406a34957 x86_64/corporate/2.1/SRPMS/mailman-2.0.14-1.3.C21mdk.src.rpm

Corporate 3.0:
e6df81bf7b44a9a02a9fc44910be76b0 corporate/3.0/RPMS/mailman-2.1.4-2.3.C30mdk.i586.rpm
d2642df15ee5a3e0bf965cf23563157c corporate/3.0/SRPMS/mailman-2.1.4-2.3.C30mdk.src.rpm

Corporate 3.0/X86_64:
5c8a3cb930e10b38fbd8639ca942f329 x86_64/corporate/3.0/RPMS/mailman-2.1.4-2.3.C30mdk.x86_64.rpm
d2642df15ee5a3e0bf965cf23563157c x86_64/corporate/3.0/SRPMS/mailman-2.1.4-2.3.C30mdk.src.rpm

Vendor URL:  mailman.sf.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Mandriva/Mandrake)
Underlying OS Comments:  10.0, 10.1, Corporate 3.0, Corporate Server 2.1

Message History:   This archive entry is a follow-up to the message listed below.
Feb 10 2005 Mailman Input Validation Hole in 'private.py' Discloses Files to Remote Users



 Source Message Contents

Subject:  [Security Announce] MDKSA-2005:037 - Updated mailman packages fix


This is a multi-part message in MIME format...

------------=_1108430751-31468-2996

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

                 Mandrakelinux Security Update Advisory
 _______________________________________________________________________

 Package name:           mailman
 Advisory ID:            MDKSA-2005:037
 Date:                   February 14th, 2005

 Affected versions:	 10.0, 10.1, Corporate 3.0,
			 Corporate Server 2.1
 ______________________________________________________________________

 Problem Description:

 A vulnerability was discovered in Mailman, which allows 
 a remote directory traversal exploit using URLs of the form
 ".../....///" to access private Mailman configuration data.
 
 The vulnerability lies in the Mailman/Cgi/private.py file.
 
 Updated packages correct this issue.
 _______________________________________________________________________

 References:

  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0202
 ______________________________________________________________________

 Updated Packages:
  
 Mandrakelinux 10.0:
 2962bcf8974ad0f4f0e47fa957a8a276  10.0/RPMS/mailman-2.1.4-2.3.100mdk.i586.rpm
 6e1afd0483efcc74c780dd2a7533263a  10.0/SRPMS/mailman-2.1.4-2.3.100mdk.src.rpm

 Mandrakelinux 10.0/AMD64:
 7b2ba12c273fd6f39b2a98a533fe1029  amd64/10.0/RPMS/mailman-2.1.4-2.3.100mdk.amd64.rpm
 6e1afd0483efcc74c780dd2a7533263a  amd64/10.0/SRPMS/mailman-2.1.4-2.3.100mdk.src.rpm

 Mandrakelinux 10.1:
 d2382f8a1d35bbf90ac29729d67f5508  10.1/RPMS/mailman-2.1.5-7.3.101mdk.i586.rpm
 d2382f8a1d35bbf90ac29729d67f5508  10.1/SRPMS/mailman-2.1.5-7.3.101mdk.i586.rpm

 Mandrakelinux 10.1/X86_64:
 d4e2e15b0e16b4cb4db4e31c01ea71a9  x86_64/10.1/RPMS/mailman-2.1.5-7.3.101mdk.x86_64.rpm
 d2382f8a1d35bbf90ac29729d67f5508  x86_64/10.1/SRPMS/mailman-2.1.5-7.3.101mdk.i586.rpm

 Corporate Server 2.1:
 eb01c4300056aec9ed25b79906ba564a  corporate/2.1/RPMS/mailman-2.0.14-1.3.C21mdk.i586.rpm
 f5bdc329649f114e49d8346406a34957  corporate/2.1/SRPMS/mailman-2.0.14-1.3.C21mdk.src.rpm

 Corporate Server 2.1/X86_64:
 eb01c4300056aec9ed25b79906ba564a  x86_64/corporate/2.1/RPMS/mailman-2.0.14-1.3.C21mdk.i586.rpm
 f5bdc329649f114e49d8346406a34957  x86_64/corporate/2.1/SRPMS/mailman-2.0.14-1.3.C21mdk.src.rpm

 Corporate 3.0:
 e6df81bf7b44a9a02a9fc44910be76b0  corporate/3.0/RPMS/mailman-2.1.4-2.3.C30mdk.i586.rpm
 d2642df15ee5a3e0bf965cf23563157c  corporate/3.0/SRPMS/mailman-2.1.4-2.3.C30mdk.src.rpm

 Corporate 3.0/X86_64:
 5c8a3cb930e10b38fbd8639ca942f329  x86_64/corporate/3.0/RPMS/mailman-2.1.4-2.3.C30mdk.x86_64.rpm
 d2642df15ee5a3e0bf965cf23563157c  x86_64/corporate/3.0/SRPMS/mailman-2.1.4-2.3.C30mdk.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrakeUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandrakesoft for security.  You can obtain
 the GPG public key of the Mandrakelinux Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandrakelinux at:

  http://www.mandrakesoft.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  <security linux-mandrake.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFCEUtamqjQ0CJFipgRAoRFAKCCVroAPga6BMXMclWtqE6lWS1xrwCg7rb4
fYywXYxwt/7kpyKR8zrWpYE=
=5476
-----END PGP SIGNATURE-----


------------=_1108430751-31468-2996
Content-Type: text/plain; name="message.footer"
Content-Disposition: inline; filename="message.footer"
Content-Transfer-Encoding: 8bit

____________________________________________________
Want to buy your Pack or Services from MandrakeSoft? 
Go to http://www.mandrakestore.com
Join the Club : http://www.mandrakeclub.com
____________________________________________________

------------=_1108430751-31468-2996--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC