SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   FreeRADIUS Vendors:   FreeRADIUS Server Project
(Fedoa Issues Fix) FreeRADIUS 'Ascend-Send-Secret' Processing Error Lets Remote Users Crash the Service
SecurityTracker Alert ID:  1013077
SecurityTracker URL:  http://securitytracker.com/id/1013077
CVE Reference:   CVE-2004-0938, CVE-2004-0960, CVE-2004-0961   (Links to External Site)
Date:  Feb 3 2005
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0.0
Description:   A vulnerability was reported in FreeRADIUS. A remote user can cause the target RADIUS service to crash.

The VulnDisco RADIUS test suite includes tests for a previously unreported denial of service vulnerability in FreeRADIUS 1.0.0.

The vendor reported that Ascend-Send-Secret, like Tunnel-Password, requires an "original" packet to decode the attribute [CVE: ]. The software checks for Tunnel-Password, but not Ascend-Send-Secret.

The flaw resides in 'radius.c' and 'eap_tls.c'.

The vendor also reported that a remote user can supply malformed USR vendor-specific attributes to invoke a memcpy() operation with a '-1' argument, causing the RADIUS service to crash [CVE: CVE-2004-0960].

The vendor also reported that a remote user can send a series of Access-Request packets with Ascend-Send-Secret, Ascend-Recv-Secret, or Tunnel-Password attributes to cause the service to consume all available memory [CVE: CVE-2004-0961].

Impact:   A remote user can cause the RADIUS service to crash.
Solution:   Fedora has released a fix.

Fedora Core 1:

SRPM:
http://download.fedoralegacy.org/fedora/1/updates/SRPMS/freeradius-1.0.1-0.FC1.5.legacy.src.rpm

i386:
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-mysql-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-postgresql-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-unixODBC-1.0.1-0.FC1.5.legacy.i386.rpm

The verification checksums are:

SHA1 sum Package Name

83a5b013fac1aaa3caee75ea97dadb9ead68ca6c
fedora/1/updates/i386/freeradius-1.0.1-0.FC1.5.legacy.i386.rpm
6b9dfc73490b32784112f0f6f0cde1d87f1812f7
fedora/1/updates/i386/freeradius-mysql-1.0.1-0.FC1.5.legacy.i386.rpm
58b1e0975443a435c982b394f775337a8eedde9a
fedora/1/updates/i386/freeradius-postgresql-1.0.1-0.FC1.5.legacy.i386.rpm
94b816b7da430f359401dade849820c962b5ad98
fedora/1/updates/i386/freeradius-unixODBC-1.0.1-0.FC1.5.legacy.i386.rpm
c26c9fe20f721946bbcf7723b654ce72d1fd587f
fedora/1/updates/SRPMS/freeradius-1.0.1-0.FC1.5.legacy.src.rpm

Vendor URL:  www.freeradius.org/ (Links to External Site)
Cause:   Exception handling error
Underlying OS:  Linux (Red Hat Fedora)
Underlying OS Comments:  FC1

Message History:   This archive entry is a follow-up to the message listed below.
Sep 20 2004 FreeRADIUS 'Ascend-Send-Secret' Processing Error Lets Remote Users Crash the Service



 Source Message Contents

Subject:  [Full-Disclosure] [FLSA-2005:2187] Updated freeradius packages fix


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--===============1910417530==
Content-type: multipart/signed;
	boundary=------------enig8F6978ECE2DAEE9B5842A269;
	protocol="application/pgp-signature"; micalg=pgp-sha1

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig8F6978ECE2DAEE9B5842A269
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

-----------------------------------------------------------------------
                Fedora Legacy Update Advisory

Synopsis:          Updated freeradius packages fix security flaws
Advisory ID:       FLSA:2187
Issue date:        2005-02-01
Product:           Fedora Core
Keywords:          Bugfix
Cross references:  https://bugzilla.fedora.us/show_bug.cgi?id=2187
CVE Names:         CAN-2004-0938 CAN-2004-0960 CAN-2004-0961
-----------------------------------------------------------------------


-----------------------------------------------------------------------
1. Topic:

Updated freeradius packages that fix a number of denial of service
vulnerabilities as well as minor bugs are now available.

FreeRADIUS is a high-performance and highly configurable free RADIUS
server designed to allow centralized authentication and authorization
for a network.

2. Relevant releases/architectures:

Fedora Core 1 - i386

3. Problem description:

A number of flaws were found in FreeRADIUS versions prior to 1.0.1. An
attacker who is able to send packets to the server could construct
carefully constructed packets in such a way as to cause the server to
consume memory or crash. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the names CAN-2004-0938,
CAN-2004-0960, and CAN-2004-0961 to these issues.

Please note that the pam config file included in these packages was
renamed to /etc/pam.d/radiusd.

Users of FreeRADIUS should update to these erratum packages that contain
FreeRADIUS 1.0.1, which is not vulnerable to these issues and also
corrects a number of bugs.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which
are not installed but included in the list will not be updated.  Note
that you can also use wildcards (*.rpm) if your current directory *only*
contains the desired RPMs.

Please note that this update is also available via yum and apt.  Many
people find this an easier way to apply updates.  To use yum issue:

yum update

or to use apt:

apt-get update; apt-get upgrade

This will start an interactive process that will result in the
appropriate RPMs being upgraded on your system.  This assumes that you
have yum or apt-get configured for obtaining Fedora Legacy content.
Please visit http://www fedoralegacy.org/docs for directions on how to
configure yum and apt-get.

5. Bug IDs fixed:

http://bugzilla.fedora.us - 2187 - Freeradius < 1.0.1 DoS and remote crash

6. RPMs required:

Fedora Core 1:

SRPM:
http://download.fedoralegacy.org/fedora/1/updates/SRPMS/freeradius-1.0.1-0.FC1.5.legacy.src.rpm

i386:
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-mysql-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-postgresql-1.0.1-0.FC1.5.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/freeradius-unixODBC-1.0.1-0.FC1.5.legacy.i386.rpm

7. Verification:

SHA1 sum                                 Package Name
---------------------------------------------------------------------------

83a5b013fac1aaa3caee75ea97dadb9ead68ca6c 
fedora/1/updates/i386/freeradius-1.0.1-0.FC1.5.legacy.i386.rpm
6b9dfc73490b32784112f0f6f0cde1d87f1812f7 
fedora/1/updates/i386/freeradius-mysql-1.0.1-0.FC1.5.legacy.i386.rpm
58b1e0975443a435c982b394f775337a8eedde9a 
fedora/1/updates/i386/freeradius-postgresql-1.0.1-0.FC1.5.legacy.i386.rpm
94b816b7da430f359401dade849820c962b5ad98 
fedora/1/updates/i386/freeradius-unixODBC-1.0.1-0.FC1.5.legacy.i386.rpm
c26c9fe20f721946bbcf7723b654ce72d1fd587f 
fedora/1/updates/SRPMS/freeradius-1.0.1-0.FC1.5.legacy.src.rpm

These packages are GPG signed by Fedora Legacy for security.  Our key is
available from http://www.fedoralegacy org/about/security.php

You can verify each package with the following command:

     rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the sha1sum with the following command:

     sha1sum <filename>

8. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0938
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0960
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0961

9. Contact:

The Fedora Legacy security contact is <secnotice@fedoralegacy.org>. More
project details at http://www.fedoralegacy.org

---------------------------------------------------------------------

--------------enig8F6978ECE2DAEE9B5842A269
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCACmaLMAs/0C4zNoRAq1AAKCHSmhWiEzYhmjmBl/QEy1q2NbnMwCeMS4N
ZmLcs1Y2JZ/nSDYTJtsZ7ow=
=GuJE
-----END PGP SIGNATURE-----

--------------enig8F6978ECE2DAEE9B5842A269--

--===============1910417530==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html

--===============1910417530==--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC