SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Client)  >   GNOME Evolution Vendors:   Gnome Development Team
(Gentoo Issues Fix) Evolution Integer Overflow in camel-lock-helper May Let Local and Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012983
SecurityTracker URL:  http://securitytracker.com/id/1012983
CVE Reference:   CVE-2005-0102   (Links to External Site)
Date:  Jan 25 2005
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, Root access via local system, Root access via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.3 and prior versions
Description:   An integer overflow vulnerability was reported in Evolution in camel-lock-helper. A remote mail server may may be able to execute arbitrary code on a connected system. A local user can execute arbitrary code with elevated privileges.

The flaw resides in 'camel-lock-helper.c', where a user-supplied length value is not properly validated. A user can supply a value of '-1' to cause a zero byte buffer to be allocated and then overflowed. A remote POP3 server can supply a specially crafted response to a connected system to execute arbitrary code on the target system. Also, a local user can invoke Evolution to execute arbitrary code with elevated privileges.

On some systems, this utility is configured with set group id (setgid) 'mail' group privileges and on other systems it is configured with set user id (setuid) 'root' user privileges.

Max Vozeler is credited with discovering this flaw.

Impact:   A remote POP3 mail server may be able to execute arbitrary code on the connected system.

A local user can execute arbitrary code on the target system.

The code may run with 'mail' group privileges or 'root' user privileges, depending on the system configuration.

Solution:   Gentoo has released a fix and indicates that all Evolution users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
# ">=mail-client/evolution-2.0.2-r1"

Vendor URL:  www.gnome.org/projects/evolution/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Jan 25 2005 Evolution Integer Overflow in camel-lock-helper May Let Local and Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-35 ] Evolution: Integer overflow in camel-lock-helper



--u5E4XgoOPWr4PD9E
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-35
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Evolution: Integer overflow in camel-lock-helper
      Date: January 24, 2005
      Bugs: #79183
        ID: 200501-35

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An overflow in the camel-lock-helper application can be exploited by an
attacker to execute arbitrary code with elevated privileges.

Background
==========

Evolution is a GNOME groupware application similar to Microsoft
Outlook.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /  Vulnerable  /                Unaffected
    -------------------------------------------------------------------
  1  mail-client/evolution      <= 2.0.2                   >= 2.0.2-r1

Description
===========

Max Vozeler discovered an integer overflow in the camel-lock-helper
application, which is installed as setgid mail by default.

Impact
======

A local attacker could exploit this vulnerability to execute malicious
code with the privileges of the 'mail' group. A remote attacker could
also setup a malicious POP server to execute arbitrary code when an
Evolution user connects to it.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Evolution users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
    # ">=mail-client/evolution-2.0.2-r1"

References
==========

  [ 1 ] CAN-2005-0102
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0102

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-35.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--u5E4XgoOPWr4PD9E
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFB9WvKRsm3eDkOu7kRAt0YAJ9UftxVehR+wqEBHBfjorGsmo6ZIACcDTv/
MfBvpk9d75FqskMC5lOUqoo=
=gBNf
-----END PGP SIGNATURE-----

--u5E4XgoOPWr4PD9E--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC