SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Instant Messaging/IRC/Chat)  >   KDE Konversation Vendors:   KDE.org
(Gentoo Issues Fix) KDE Konversation Bugs May Allow a Remote User to Cause Command Execution on a Target User's System
SecurityTracker Alert ID:  1012982
SecurityTracker URL:  http://securitytracker.com/id/1012982
CVE Reference:   CVE-2005-0129, CVE-2005-0130, CVE-2005-0131   (Links to External Site)
Date:  Jan 25 2005
Impact:   Disclosure of authentication information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 0.15 and prior versions
Description:   Several vulnerabilities were reported in the KDE Konversation software. A remote user may be able to cause a target user to execute arbitrary commands. A target user may disclose their password to other users.

Wouter Coekaerts reported that the software does not properly expand %-escaped variables in certain input strings due to a flaw in the 'Server::parseWildcards' function [CVE: CVE-2005-0129]. A remote user may be able to cause a target user to execute shell commands.

Some Konversation perl scripts do not properly validate command line inputs, such as the $SERVER or $TARGET parameters [CVE: CVE-2005-0130]. A remote user may be able to get a target user to join a specially named channel. Then, if the target user runs a script in that channel, arbitrary shell commands may be executed on the target user's system.

The nick and password parameters are confused in the quick connection dialog, so a target user connecting with that dialog may expose their password [CVE: CVE-2005-0131].

The vendor was notified on January 18, 2005.

Impact:   A remote user may be able to cause a target user to execute arbitrary commands when the target user takes certain actions.

A target user may disclose their password to remote users.

Solution:   Gentoo has released a fix and indicates that all Konversation users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-irc/konversation-0.15.1"

Vendor URL:  www.kde.org/info/security/advisory-20050121-1.txt (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Jan 24 2005 KDE Konversation Bugs May Allow a Remote User to Cause Command Execution on a Target User's System



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-34 ] Konversation: Various vulnerabilities



--IrhDeMKUP4DT/M7F
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-34
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Konversation: Various vulnerabilities
      Date: January 24, 2005
      Bugs: #78712
        ID: 200501-34

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Konversation contains multiple vulnerabilities that could lead to
remote command execution or information leaks.

Background
==========

Konversation is a user-friendly IRC client for KDE.

Affected packages
=================

    -------------------------------------------------------------------
     Package               /  Vulnerable  /                 Unaffected
    -------------------------------------------------------------------
  1  net-irc/konversation      < 0.15.1                      >= 0.15.1

Description
===========

Wouter Coekaerts has discovered three vulnerabilites within
Konversation:

* The Server::parseWildcards function, which is used by the "Quick
  Buttons", does not properly handle variable expansion
  (CAN-2005-0129).

* Perl scripts included with Konversation do not properly escape
  shell metacharacters (CAN-2005-0130).

* The 'Nick' and 'Password' fields in the Quick Connect dialog can be
  easily confused (CAN-2005-0131).

Impact
======

A malicious server could create specially-crafted channels, which would
exploit certain flaws in Konversation, potentially leading to the
execution of shell commands. A user could also unintentionally input
their password into the 'Nick' field in the Quick Connect dialog,
exposing his password to IRC users, and log files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Konversation users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-irc/konversation-0.15.1"

References
==========

  [ 1 ] CAN-2005-0129
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0129
  [ 2 ] CAN-2005-0130
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0130
  [ 3 ] CAN-2005-0131
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0131
  [ 4 ] KDE Security Advisory: Multiple vulnerabilities in Konversation
        http://www.kde.org/info/security/advisory-20050121-1.txt

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-34.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--IrhDeMKUP4DT/M7F
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFB9QjFRsm3eDkOu7kRAmF1AJ45K18m+Ka0zBexRsK6FGcbOEjojQCcCZwK
tHcDFQjrevViAt5pvthT7Zw=
=9kZv
-----END PGP SIGNATURE-----

--IrhDeMKUP4DT/M7F--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC