SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Multimedia)  >   Playmidi Vendors:   Laredo, Nathan
(Mandrake Issues Fix) Playmidi Buffer Overflow in Processing Filename May Let Local Users Obtain Elevated Privileges
SecurityTracker Alert ID:  1012960
SecurityTracker URL:  http://securitytracker.com/id/1012960
CVE Reference:   CVE-2005-0020   (Links to External Site)
Date:  Jan 21 2005
Impact:   Execution of arbitrary code via local system, Root access via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.5 and prior versions
Description:   A buffer overflow vulnerability was reported in playmidi. A local user can execute arbitrary code, potentially with elevated privileges.

Various Linux distribution vendors reported that a local user can trigger a buffer overflow in the processing of the filename. If the application is installed with set user id (setuid) privileges, a local user can execute arbitrary code with elevated privileges.

The flaw resides in 'playmidi.c'.

Erik Sjolund is credited with discovering this flaw.

Impact:   A local user can execute arbitrary code with the privileges of playmidi. On some systems, this may yield root user privileges.
Solution:   Mandrake has released a fix.

Mandrakelinux 10.0:
11b39014c3c354c549f4b510d0e59ad5 10.0/RPMS/playmidi-2.5-3.1.100mdk.i586.rpm
930ad98832bc68b4f2d97cde16fbb589 10.0/RPMS/playmidi-X11-2.5-3.1.100mdk.i586.rpm
ac2bef9ddcba160bf52f9a883c759fdf 10.0/SRPMS/playmidi-2.5-3.1.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
629089b1281e17784bd3fc4d69d8424a amd64/10.0/RPMS/playmidi-2.5-3.1.100mdk.amd64.rpm
d8cf76271cfab47e597090400c32ca4a amd64/10.0/RPMS/playmidi-X11-2.5-3.1.100mdk.amd64.rpm
ac2bef9ddcba160bf52f9a883c759fdf amd64/10.0/SRPMS/playmidi-2.5-3.1.100mdk.src.rpm

Mandrakelinux 10.1:
1be61eeb85b0c916771fc5a834691835 10.1/RPMS/playmidi-2.5-3.1.101mdk.i586.rpm
e43429abba5378ab18d5d8cb1b61c345 10.1/RPMS/playmidi-X11-2.5-3.1.101mdk.i586.rpm
c1958aeb4fe6a620b43c90581c5cbef8 10.1/SRPMS/playmidi-2.5-3.1.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
acbe49ee3b86227a0757cd8ebf7b1d08 x86_64/10.1/RPMS/playmidi-2.5-3.1.101mdk.x86_64.rpm
3f1bd829359d1d5b26d879ca3ed20c8b x86_64/10.1/RPMS/playmidi-X11-2.5-3.1.101mdk.x86_64.rpm
c1958aeb4fe6a620b43c90581c5cbef8 x86_64/10.1/SRPMS/playmidi-2.5-3.1.101mdk.src.rpm

Corporate Server 3.0:
ee62926bf969895976b99bafb79d12a6 corporate/3.0/RPMS/playmidi-2.5-3.1.C30mdk.i586.rpm
983da3f98fd776bdeb484ce6228e8a8d corporate/3.0/RPMS/playmidi-X11-2.5-3.1.C30mdk.i586.rpm
70a3be81e9afce9341faf9ce61e7e60a corporate/3.0/SRPMS/playmidi-2.5-3.1.C30mdk.src.rpm

Vendor URL:  playmidi.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Mandriva/Mandrake)
Underlying OS Comments:  10.0, 10.1, Corporate Server 3.0

Message History:   This archive entry is a follow-up to the message listed below.
Jan 20 2005 Playmidi Buffer Overflow in Processing Filename May Let Local Users Obtain Elevated Privileges



 Source Message Contents

Subject:  [Security Announce] MDKSA-2005:010 - Updated playmidi packages


This is a multi-part message in MIME format...

------------=_1106173270-1462-1984

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

                 Mandrakelinux Security Update Advisory
 _______________________________________________________________________

 Package name:           playmidi
 Advisory ID:            MDKSA-2005:010
 Date:                   January 19th, 2005

 Affected versions:	 10.0, 10.1, Corporate Server 3.0
 ______________________________________________________________________

 Problem Description:

 Erik Sjolund discovered a buffer overflow in playmidi that could be
 exploited by a local attacker if installed setuid root.  Note that by
 default Mandrakelinux does not ship playmidi installed setuid root.
 _______________________________________________________________________

 References:

  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0020
 ______________________________________________________________________

 Updated Packages:
  
 Mandrakelinux 10.0:
 11b39014c3c354c549f4b510d0e59ad5  10.0/RPMS/playmidi-2.5-3.1.100mdk.i586.rpm
 930ad98832bc68b4f2d97cde16fbb589  10.0/RPMS/playmidi-X11-2.5-3.1.100mdk.i586.rpm
 ac2bef9ddcba160bf52f9a883c759fdf  10.0/SRPMS/playmidi-2.5-3.1.100mdk.src.rpm

 Mandrakelinux 10.0/AMD64:
 629089b1281e17784bd3fc4d69d8424a  amd64/10.0/RPMS/playmidi-2.5-3.1.100mdk.amd64.rpm
 d8cf76271cfab47e597090400c32ca4a  amd64/10.0/RPMS/playmidi-X11-2.5-3.1.100mdk.amd64.rpm
 ac2bef9ddcba160bf52f9a883c759fdf  amd64/10.0/SRPMS/playmidi-2.5-3.1.100mdk.src.rpm

 Mandrakelinux 10.1:
 1be61eeb85b0c916771fc5a834691835  10.1/RPMS/playmidi-2.5-3.1.101mdk.i586.rpm
 e43429abba5378ab18d5d8cb1b61c345  10.1/RPMS/playmidi-X11-2.5-3.1.101mdk.i586.rpm
 c1958aeb4fe6a620b43c90581c5cbef8  10.1/SRPMS/playmidi-2.5-3.1.101mdk.src.rpm

 Mandrakelinux 10.1/X86_64:
 acbe49ee3b86227a0757cd8ebf7b1d08  x86_64/10.1/RPMS/playmidi-2.5-3.1.101mdk.x86_64.rpm
 3f1bd829359d1d5b26d879ca3ed20c8b  x86_64/10.1/RPMS/playmidi-X11-2.5-3.1.101mdk.x86_64.rpm
 c1958aeb4fe6a620b43c90581c5cbef8  x86_64/10.1/SRPMS/playmidi-2.5-3.1.101mdk.src.rpm

 Corporate Server 3.0:
 ee62926bf969895976b99bafb79d12a6  corporate/3.0/RPMS/playmidi-2.5-3.1.C30mdk.i586.rpm
 983da3f98fd776bdeb484ce6228e8a8d  corporate/3.0/RPMS/playmidi-X11-2.5-3.1.C30mdk.i586.rpm
 70a3be81e9afce9341faf9ce61e7e60a  corporate/3.0/SRPMS/playmidi-2.5-3.1.C30mdk.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrakeUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandrakesoft for security.  You can obtain
 the GPG public key of the Mandrakelinux Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandrakelinux at:

  http://www.mandrakesoft.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  <security linux-mandrake.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB7tommqjQ0CJFipgRAoB5AKDsUDE/2fU6ZBO1B3cRNmFixIj5agCgiJEu
7hQjmvJKEWuufOC/JE6Z4uA=
=07V0
-----END PGP SIGNATURE-----


------------=_1106173270-1462-1984
Content-Type: text/plain; name="message.footer"
Content-Disposition: inline; filename="message.footer"
Content-Transfer-Encoding: 8bit

____________________________________________________
Want to buy your Pack or Services from MandrakeSoft? 
Go to http://www.mandrakestore.com
Join the Club : http://www.mandrakeclub.com
____________________________________________________

------------=_1106173270-1462-1984--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC