SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   httpd (OpenBSD) Vendors:   OpenBSD
OpenBSD httpd mod_include Local Buffer Overflow Has Unspecified Impact
SecurityTracker Alert ID:  1012865
SecurityTracker URL:  http://securitytracker.com/id/1012865
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Jan 12 2005
Impact:   Not specified
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in OpenBSD httpd(8) in the mod_include module. A local user can trigger a buffer overflow. The impact was not specified.

The vendor reported that mod_include does not properly validate the length of user supplied tag strings. If the XBitHack directive is enabled or if server-side includes are enabled, a local user can create a specially crafted document that, when processed by the web server, will trigger the buffer overflow.

Impact:   The impact was not specified.
Solution:   The vendor has issued the following patches:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.5/common/026_httpd3.patch
ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.6/common/009_httpd.patch

Vendor URL:  www.openbsd.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  UNIX (OpenBSD)
Underlying OS Comments:  3.5, 3.6

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC