SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Browser)  >   KDE Konqueror Vendors:   KDE.org
(Gentoo Issues Fix) KDE Konqueror Input Validation Error in Processing FTP URLs May Let Remote Users Inject Arbitrary FTP Commands
SecurityTracker Alert ID:  1012844
SecurityTracker URL:  http://securitytracker.com/id/1012844
CVE Reference:   CVE-2004-1165   (Links to External Site)
Date:  Jan 12 2005
Impact:   Execution of arbitrary code via network, Host/resource access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.3.1 and prior versions
Description:   A vulnerability was reported in KDE Konqueror in the processing of FTP URLs. A remote user may be able to cause FTP commands to be executed.

Albert Puigsech Galicia reported that a remote user can create a specially crafted FTP URL that, when loaded by the target user, will execute arbitrary FTP commands on the specified FTP server. The commands can be appended to the URL, separated by the string '%0a'. A demonstration exploit URL is of the following format:

ftp://ftpuser:ftppass@server/directory%0asomecommand%0a

The target user must first be authenticated against the FTP server for the exploit to work.

The vendor was notified on December 2, 2004.

Impact:   A remote user can create a URL that, when loaded by the target user, may execute arbitrary FTP commands on the specified FTP server.
Solution:   Gentoo has released a fix and indicates that all kdelibs users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdelibs

Vendor URL:  www.kde.org/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 7 2004 KDE Konqueror Input Validation Error in Processing FTP URLs May Let Remote Users Inject Arbitrary FTP Commands



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-18 ] KDE FTP KIOslave: Command injection


--nextPart1376224.vfgbXof34N
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: KDE FTP KIOslave: Command injection
      Date: January 11, 2005
      Bugs: #73759
        ID: 200501-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The FTP KIOslave contains a bug allowing users to execute arbitrary FTP
commands.

Background
==========

KDE is a feature-rich graphical desktop environment for Linux and
Unix-like Operating Systems. KDE provided KIOslaves for many protocols
in the kdelibs package, one of them being FTP. These are used by KDE
applications such as Konqueror.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  kde-base/kdelibs     < 3.3.2-r2                       >= 3.3.2-r2
                                                          *>= 3.2.3-r5

Description
===========

The FTP KIOslave fails to properly parse URL-encoded newline
characters.

Impact
======

An attacker could exploit this to execute arbitrary FTP commands on the
server and due to similiarities between the FTP and the SMTP protocol,
this vulnerability also allows an attacker to connect to a SMTP server
and issue arbitrary commands, for example sending an email.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All kdelibs users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose kde-base/kdelibs

Note: There is currently no fixed stable 3.3.x version for sparc.

References
==========

  [ 1 ] KDE Security Advisory: ftp kioslave command injection
        http://www.kde.org/info/security/advisory-20050101-1.txt
  [ 2 ] CAN-2004-1165
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1165

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart1376224.vfgbXof34N
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBB49WbzKC5hMHO6rkRAlyhAJ9UAm9Z7haLxgOGHuR/2g0XyGV0dgCfbqn7
qnWuWPoBcG7Un+yg5GHdmA0=
=R8xh
-----END PGP SIGNATURE-----

--nextPart1376224.vfgbXof34N--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC