SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   pdftohtml Vendors:   pdftohtml.sourceforge.net
(Gentoo Issues Fix for pdftohtml) Xpdf Buffer Overflow in doImage() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012816
SecurityTracker URL:  http://securitytracker.com/id/1012816
CVE Reference:   CVE-2004-1125   (Links to External Site)
Date:  Jan 10 2005
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   iDEFENSE reported a buffer overflow vulnerability in Xpdf. A remote user can cause arbitrary code to be executed on the target user's system. pdftohtml is affected.

It is reported that a remote user can create a specially crafted PDF file that, when viewed by the target user, will trigger an overflow and execute arbitrary code with the privileges of the target user.

The flaw resides in the Gfx::doImage() function in 'xpdf/Gfx.cc', where the maskColors array can be overflowed.

The vendor was notified on November 23, 2004.

The original advisory is available at:

http://www.idefense.com/application/poi/display?id=172&type=vulnerabilities

Impact:   A remote user can create a specially crafted PDF file that, when viewed by the target user, will execute arbitrary code on the target user's system. The code will run with the privileges of the target user.
Solution:   Gentoo has released a fix for pdftohtml, which is affected by the Xpdf vulnerability.

All pdftohtml users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/pdftohtml-0.36-r2"

Vendor URL:  pdftohtml.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 21 2004 Xpdf Buffer Overflow in doImage() Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-13 ] pdftohtml: Vulnerabilities in included Xpdf


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig79BB8FE296CE928A93B7812B
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: pdftohtml: Vulnerabilities in included Xpdf
      Date: January 10, 2005
      Bugs: #75200
        ID: 200501-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

pdftohtml includes vulnerable Xpdf code to handle PDF files, making it
vulnerable to execution of arbitrary code upon converting a malicious
PDF file.

Background
==========

pdftohtml is a utility to convert PDF files to HTML or XML formats. It
makes use of Xpdf code to decode PDF files.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  app-text/pdftohtml      < 0.36-r2                      >= 0.36-r2

Description
===========

Xpdf is vulnerable to integer overflows, as described in GLSA
200412-24.

Impact
======

An attacker could entice a user to convert a specially-crafted PDF
file, potentially resulting in the execution of arbitrary code with the
rights of the user running pdftohtml.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All pdftohtml users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/pdftohtml-0.36-r2"

References
==========

  [ 1 ] GLSA 200412-24
        http://www.gentoo.org/security/en/glsa/glsa-200410-20.xml
  [ 2 ] CAN-2004-1125
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1125

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enig79BB8FE296CE928A93B7812B
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB4ke2vcL1obalX08RAt2MAJ4iyFOJFj0JOtDY/qi22nyHh0SXOQCglwhJ
a6mfv/Jg9Yg7qkvQILyO0R0=
=Te/T
-----END PGP SIGNATURE-----

--------------enig79BB8FE296CE928A93B7812B--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC