SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   Kerberos Vendors:   MIT
(Gentoo Issues Fix) Kerberos libkadm5srv Heap Overflow in Processing Password History May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012786
SecurityTracker URL:  http://securitytracker.com/id/1012786
CVE Reference:   CVE-2004-1189   (Links to External Site)
Date:  Jan 6 2005
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): krb5-1.3.5 and prior versions
Description:   A buffer overflow vulnerability was reported in Kerberos 5 in the libkadm5srv administration library. A remote user may be able to execute arbitrary code on an affected Key Distribution Center (KDC) host.

The vendor reported that there is a heap overflow in the password history handling code. If an administrator has performed a certain password policy change, the system may be affected.

The flaw resides in the add_to_history() function in 'src/lib/kadm5/srv/svr_principal.c', where an array index may be set to an out-of-bounds position, causing a password history to be written past the end of an array.

Michael Tautschnig is credited with reporting this flaw.

Impact:   A remote user may be able to execute arbitrary code on the target KDC system in certain cases.
Solution:   Gentoo has released a fix and indicates that all mit-krb5 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-crypt/mit-krb5-1.3.6"

Vendor URL:  web.mit.edu/kerberos/advisories/MITKRB5-SA-2004-004-pwhist.txt (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 20 2004 Kerberos libkadm5srv Heap Overflow in Processing Password History May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200501-05 ] mit-krb5: Heap overflow in libkadm5srv


--nextPart85009608.B33xPE238U
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: mit-krb5: Heap overflow in libkadm5srv
      Date: January 05, 2005
      Bugs: #75143
        ID: 200501-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The MIT Kerberos 5 administration library (libkadm5srv) contains a heap
overflow that could lead to execution of arbitrary code.

Background
==========

MIT krb5 is the free implementation of the Kerberos network
authentication protocol by the Massachusetts Institute of Technology.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  app-crypt/mit-krb5       < 1.3.6                         >= 1.3.6

Description
===========

The MIT Kerberos 5 administration library libkadm5srv contains a heap
overflow in the code handling password changing.

Impact
======

Under specific circumstances an attacker could execute arbitary code
with the permissions of the user running mit-krb5, which could be the
root user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All mit-krb5 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-crypt/mit-krb5-1.3.6"

References
==========

  [ 1 ] CAN 2004-1189
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1189

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200501-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart85009608.B33xPE238U
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBB3GHWzKC5hMHO6rkRAiZyAJ95SIB9mKLcXqY0EMQMo+d7UNtbUwCeIR8X
5fuIGQRiKYm3XhsIucKDGDo=
=ToTD
-----END PGP SIGNATURE-----

--nextPart85009608.B33xPE238U--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC