SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Calendar)  >   pcal Vendors:   pcal.sourceforge.net
(Debian Issues Fix) pcal Buffer Overflows Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012780
SecurityTracker URL:  http://securitytracker.com/id/1012780
CVE Reference:   CVE-2004-1289   (Links to External Site)
Date:  Jan 6 2005
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Two vulnerabilities were reported in pcal. A remote user can cause arbitrary code to be executed by the target user.

D. J. Bernstein reported that a remote user can create a specially crafted calendar file that, when processed by the target user with pcal, will execute arbitrary code on the target user's system. The code will run with the privileges of the target user.

The buffer overflows reside in the getline() function in 'pcalutil.c' and the get_holiday() function in 'readfile.c'.

Danny Lungstrom is credited with discovering these flaws.

Impact:   A remote user can cause arbitrary code to be executed by the target user with the privileges of the target user.
Solution:   Debian has released a fix.

Debian GNU/Linux 3.0 alias woody:

Source archives:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1.dsc
Size/MD5 checksum: 567 084db6ff500acb07787520fbe64fe55c
http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1.diff.gz
Size/MD5 checksum: 9241 dfead422c9e896806a1f3d6bf27906cd
http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7.orig.tar.gz
Size/MD5 checksum: 244559 1c3a5694c465e702795ba53dbbb1f412

Alpha architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_alpha.deb
Size/MD5 checksum: 124958 4bd681850f08a22ff4e2b409c74d34fc

ARM architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_arm.deb
Size/MD5 checksum: 110892 01e26a1ae460e156debbc26f2657048a

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_i386.deb
Size/MD5 checksum: 107250 a487a36516ae170cab2c60370352b4ad

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_ia64.deb
Size/MD5 checksum: 139992 66232d332593c1b9a1b1bdbe839f3327

HP Precision architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_hppa.deb
Size/MD5 checksum: 121282 ee138b5220ff6caf4f6ecd30f4539037

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_m68k.deb
Size/MD5 checksum: 104702 e9930289c67b6d611e51ef954724f5b4

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_mips.deb
Size/MD5 checksum: 119802 1ea25df3c512c07249fff7b6e2d08ad9

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_mipsel.deb
Size/MD5 checksum: 119766 d3c55f4e572337088ebe5cc2753e2a20

PowerPC architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_powerpc.deb
Size/MD5 checksum: 116472 034b734141ee6804d4b2f54fbba70724

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_s390.deb
Size/MD5 checksum: 109908 76455e1b97a3ba92aafcdee086916f98

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_sparc.deb
Size/MD5 checksum: 112900 a705775dedf8d2918f1016d884db48ad

Vendor URL:  pcal.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Debian)
Underlying OS Comments:  3.0

Message History:   This archive entry is a follow-up to the message listed below.
Dec 16 2004 pcal Buffer Overflows Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [SECURITY] [DSA 625-1] New pcal packages fix arbitrary code execution


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 625-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 5th, 2004                       http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : pcal
Vulnerability  : buffer overflows
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2004-1289
Debian Bug     : 287039

Danny Lungstrom discovered two buffer overflows in pcal, a program to
generate Postscript calendars, that could lead to the execution of
arbitrary code when compiling a calendar.

For the stable distribution (woody) these problems have been fixed in
version 4.7-8woody1.

For the unstable distribution (sid) these problems have been fixed in
version 4.8.0-1.

We recommend that you upgrade your pcal package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1.dsc
      Size/MD5 checksum:      567 084db6ff500acb07787520fbe64fe55c
    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1.diff.gz
      Size/MD5 checksum:     9241 dfead422c9e896806a1f3d6bf27906cd
    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7.orig.tar.gz
      Size/MD5 checksum:   244559 1c3a5694c465e702795ba53dbbb1f412

  Alpha architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_alpha.deb
      Size/MD5 checksum:   124958 4bd681850f08a22ff4e2b409c74d34fc

  ARM architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_arm.deb
      Size/MD5 checksum:   110892 01e26a1ae460e156debbc26f2657048a

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_i386.deb
      Size/MD5 checksum:   107250 a487a36516ae170cab2c60370352b4ad

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_ia64.deb
      Size/MD5 checksum:   139992 66232d332593c1b9a1b1bdbe839f3327

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_hppa.deb
      Size/MD5 checksum:   121282 ee138b5220ff6caf4f6ecd30f4539037

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_m68k.deb
      Size/MD5 checksum:   104702 e9930289c67b6d611e51ef954724f5b4

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_mips.deb
      Size/MD5 checksum:   119802 1ea25df3c512c07249fff7b6e2d08ad9

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_mipsel.deb
      Size/MD5 checksum:   119766 d3c55f4e572337088ebe5cc2753e2a20

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_powerpc.deb
      Size/MD5 checksum:   116472 034b734141ee6804d4b2f54fbba70724

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_s390.deb
      Size/MD5 checksum:   109908 76455e1b97a3ba92aafcdee086916f98

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/p/pcal/pcal_4.7-8woody1_sparc.deb
      Size/MD5 checksum:   112900 a705775dedf8d2918f1016d884db48ad


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFB2/4YW5ql+IAeqTIRAhaJAKCrZZpxYBWn4ECUM5jRp8qmeldW1wCeIOX9
hAanrmtdivrs5464RYNa0nM=
=KCn+
-----END PGP SIGNATURE-----


-- 
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC