SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   PHProjekt Vendors:   Guenther, Albrecht
(Gentoo Issues Fix) PHProjekt 'authform.inc.php' Include File Flaw Lets Remote Users Execute Arbitrary Command
SecurityTracker Alert ID:  1012738
SecurityTracker URL:  http://securitytracker.com/id/1012738
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Dec 31 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.2.2
Description:   Phil C. reported a vulnerability in PHProjekt in 'authform.inc.php'. A remote user can execute arbitrary commands on the target system.

It is reported that a remote user can supply a specially crafted $path_pre variable to cause 'authform.inc.php' to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   Gentoo has released a fix and indicates that all PHProjekt users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/phprojekt-4.2-r2"

Vendor URL:  www.phprojekt.com/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 28 2004 PHProjekt 'authform.inc.php' Include File Flaw Lets Remote Users Execute Arbitrary Command



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200412-27 ] PHProjekt: Remote code execution vulnerability


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig4379BCF9F05877FA60578097
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200412-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PHProjekt: Remote code execution vulnerability
      Date: December 30, 2004
      Bugs: #75858
        ID: 200412-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PHProjekt contains a vulnerability that allows a remote attacker to
execute arbitrary PHP code.

Background
==========

PHProjekt is a modular groupware web application used to coordinate
group activities and share files.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/phprojekt      < 4.2-r2                        >= 4.2-r2

Description
===========

cYon discovered that the authform.inc.php script allows a remote user
to define the global variable $path_pre.

Impact
======

A remote attacker can exploit this vulnerability to force
authform.inc.php to download and execute arbitrary PHP code with the
privileges of the web server user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHProjekt users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/phprojekt-4.2-r2"

References
==========

  [ 1 ] PHProjekt Advisory

http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=193&mode=thread&order=0

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200412-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enig4379BCF9F05877FA60578097
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB1BFsvcL1obalX08RAuL5AJwNcpxaAu0FT27dmRCdmNYtF+EBPACdE4/B
Ccwda0K7nQiDzMj/ObHNjyw=
=bDfM
-----END PGP SIGNATURE-----

--------------enig4379BCF9F05877FA60578097--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC