SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   gpdf Vendors:   Gnome Development Team
(Gentoo Issues Fix for GPdf) Xpdf Buffer Overflow in doImage() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012711
SecurityTracker URL:  http://securitytracker.com/id/1012711
CVE Reference:   CVE-2004-1125   (Links to External Site)
Date:  Dec 29 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   iDEFENSE reported a buffer overflow vulnerability in Xpdf. A remote user can cause arbitrary code to be executed on the target user's system. GPdf is affected.

It is reported that a remote user can create a specially crafted PDF file that, when viewed by the target user, will trigger an overflow and execute arbitrary code with the privileges of the target user.

The flaw resides in the Gfx::doImage() function in 'xpdf/Gfx.cc', where the maskColors array can be overflowed.

The vendor was notified on November 23, 2004.

The original advisory is available at:

http://www.idefense.com/application/poi/display?id=172&type=vulnerabilities

Impact:   A remote user can create a specially crafted PDF file that, when viewed by the target user, will execute arbitrary code on the target user's system. The code will run with the privileges of the target user.
Solution:   Gentoo has released a fix for GPdf and indicates that all GPdf users should also upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-2.8.1-r1"

Vendor URL:  www.inf.tu-dresden.de/~mk793652/gpdf/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 21 2004 Xpdf Buffer Overflow in doImage() Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200412-24 ] Xpdf, GPdf: New integer overflows


This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigDAA1FAD4A78DE2DAAC9AEC7C
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200412-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Xpdf, GPdf: New integer overflows
      Date: December 28, 2004
      Bugs: #75191, #75201
        ID: 200412-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

New integer overflows were discovered in Xpdf, potentially resulting in
the execution of arbitrary code. GPdf includes Xpdf code and therefore
is vulnerable to the same issues.

Background
==========

Xpdf is an open source viewer for Portable Document Format (PDF) files.
GPdf is a Gnome-based PDF viewer that includes some Xpdf code.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /  Vulnerable  /                        Unaffected
    -------------------------------------------------------------------
  1  app-text/xpdf     <= 3.00-r6                           >= 3.00-r7
  2  app-text/gpdf      <= 2.8.1                           >= 2.8.1-r1
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

A new integer overflow issue was discovered in Xpdf's Gfx::doImage()
function.

Impact
======

An attacker could entice an user to open a specially-crafted PDF file,
potentially resulting in execution of arbitrary code with the rights of
the user running Xpdf or GPdf.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Xpdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.00-r7"

All GPdf users should also upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.8.1-r1"

References
==========

  [ 1 ] CAN-2004-1125
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1125
  [ 2 ] iDEFENSE Advisory

http://www.idefense.com/application/poi/display?id=172&type=vulnerabilities&flashstatus=true

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200412-24.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enigDAA1FAD4A78DE2DAAC9AEC7C
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB0Vp5vcL1obalX08RAoQnAKCm0lokGlUEft8a/qgZ7/fJPOwgBACfUUAi
Kev6Lc6pkdACVRPS4b3oI0o=
=fyyD
-----END PGP SIGNATURE-----

--------------enigDAA1FAD4A78DE2DAAC9AEC7C--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC