SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Game)  >   atari800 Vendors:   Atari
(Debian Issues Fix) Atari800 Buffer Overflow in Atari800_Initialise() May Let Local Users Gain Root Privileges
SecurityTracker Alert ID:  1012545
SecurityTracker URL:  http://securitytracker.com/id/1012545
CVE Reference:   CVE-2004-1076   (Links to External Site)
Date:  Dec 16 2004
Impact:   Execution of arbitrary code via local system, Root access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.3.1
Description:   A vulnerability was reported in Atari800. A local user may be able to obtain root privileges.

Adam Zabrocki reported that there is a flaw in the Atari800_Initialise() function. A local user can execute arbitrary code with root privileges.

Impact:   A local user can execute arbitrary code with root privileges.
Solution:   Debian has released a fix.

Debian GNU/Linux 3.0 alias woody:

Source archives:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3.dsc
Size/MD5 checksum: 652 ca843252c5698eb4df665ba61a26f449
http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3.diff.gz
Size/MD5 checksum: 17761 2ffbb3a4956a7ad09e59562345f9bef2
http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2.orig.tar.gz
Size/MD5 checksum: 460211 17f40bab7f2cdf2968df46e37285dcd1

Alpha architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_alpha.deb
Size/MD5 checksum: 298862 a6fd1bdaba8d397f1774906671361ca4

ARM architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_arm.deb
Size/MD5 checksum: 236750 5994fb6118295471dd2892e81189c98b

Intel IA-32 architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_i386.deb
Size/MD5 checksum: 281702 0f3196118b5d4a69a42330de0a6a32d1

Intel IA-64 architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_ia64.deb
Size/MD5 checksum: 339510 179a1fa280a1233dad44166a636b0982

HP Precision architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_hppa.deb
Size/MD5 checksum: 257144 4c72048930a2cebba2d758447b144c4d

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_m68k.deb
Size/MD5 checksum: 197016 a171957e3de9101bc498fa06cd5774e7

Big endian MIPS architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_mips.deb
Size/MD5 checksum: 259956 7c548633fe1a7419f673d35e692d0f3d

Little endian MIPS architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_mipsel.deb
Size/MD5 checksum: 258570 707384b7d7779775a072f2cb224eeb26

PowerPC architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_powerpc.deb
Size/MD5 checksum: 238792 999117105a05f60ea65e037bc41570aa

IBM S/390 architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_s390.deb
Size/MD5 checksum: 235058 76acc2c010652f6a15881786df8d093f

Sun Sparc architecture:

http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_sparc.deb
Size/MD5 checksum: 239854 ac895137cfa772120ec5149823b8a8ea

Vendor URL:  atari800.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Debian)
Underlying OS Comments:  3.0

Message History:   This archive entry is a follow-up to the message listed below.
Nov 26 2004 Atari800 Buffer Overflow in Atari800_Initialise() May Let Local Users Gain Root Privileges



 Source Message Contents

Subject:  [SECURITY] [DSA 609-1] New atari800 packages fix local root exploit


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 609-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
December 14th, 2004                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : atari800
Vulnerability  : buffer overflows
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2004-1076

Adam Zabrocki discovered multiple buffer overflows in atari800, an
Atari emulator.  In order to directly access graphics hardware, one of
the affected programs is installed setuid root.  A local attacker
could exploit this vulnerability to gain root privileges.

For the stable distribution (woody) these problems have been fixed in
version 1.2.2-1woody3.

For the unstable distribution (sid) these problems will be fixed soon.

We recommend that you upgrade your atari800 package immediately.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3.dsc
      Size/MD5 checksum:      652 ca843252c5698eb4df665ba61a26f449
    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3.diff.gz
      Size/MD5 checksum:    17761 2ffbb3a4956a7ad09e59562345f9bef2
    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2.orig.tar.gz
      Size/MD5 checksum:   460211 17f40bab7f2cdf2968df46e37285dcd1

  Alpha architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_alpha.deb
      Size/MD5 checksum:   298862 a6fd1bdaba8d397f1774906671361ca4

  ARM architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_arm.deb
      Size/MD5 checksum:   236750 5994fb6118295471dd2892e81189c98b

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_i386.deb
      Size/MD5 checksum:   281702 0f3196118b5d4a69a42330de0a6a32d1

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_ia64.deb
      Size/MD5 checksum:   339510 179a1fa280a1233dad44166a636b0982

  HP Precision architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_hppa.deb
      Size/MD5 checksum:   257144 4c72048930a2cebba2d758447b144c4d

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_m68k.deb
      Size/MD5 checksum:   197016 a171957e3de9101bc498fa06cd5774e7

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_mips.deb
      Size/MD5 checksum:   259956 7c548633fe1a7419f673d35e692d0f3d

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_mipsel.deb
      Size/MD5 checksum:   258570 707384b7d7779775a072f2cb224eeb26

  PowerPC architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_powerpc.deb
      Size/MD5 checksum:   238792 999117105a05f60ea65e037bc41570aa

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_s390.deb
      Size/MD5 checksum:   235058 76acc2c010652f6a15881786df8d093f

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/contrib/a/atari800/atari800_1.2.2-1woody3_sparc.deb
      Size/MD5 checksum:   239854 ac895137cfa772120ec5149823b8a8ea


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBvw60W5ql+IAeqTIRAq1pAJ9PM25ZOUAkf2UoeU4vcA2v0S+2tgCfX2ES
kXgWZXuZGCi8sQkbOSPFOT4=
=LKTM
-----END PGP SIGNATURE-----


-- 
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC