SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Multimedia)  >   PDFlib Vendors:   PDFlib GmbH
(Gentoo Issues Fix for PDFlib) LibTIFF Buffer Overflows May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012428
SecurityTracker URL:  http://securitytracker.com/id/1012428
CVE Reference:   CVE-2004-0803   (Links to External Site)
Date:  Dec 6 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Some buffer overflow vulnerabilities were reported in LibTIFF. A remote user may be able to execute arbitrary code on the target user's system. PDFlib is affected.

Gentoo reported that a remote user may be able to create a specially crafted image file that, when processed by the library, will execute arbitrary code with the privileges of the target user.

Chris Evans is credited with discovering these flaws.

The flaws reside in the RLE decoding routines in tif_next.c, tif_thunder.c, and potentially tif_luv.c.

Some demonstration exploit TIFFs are available at:

http://scary.beasts.org/misc/bad_next.tiff

http://scary.beasts.org/misc/bad_thunder.tiff

The original advisory is available at:

http://scary.beasts.org/security/CESA-2004-006.txt

Impact:   A remote user can create TIFF files that, when loaded by the target library, will execute arbitrary code.
Solution:   Gentoo has released a fix for PDFlib, which is affected by the LibTIFF vulnerability. Gentoo indicates that all PDFlib users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/pdflib-5.0.4_p1"

Vendor URL:  www.pdflib.com/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Oct 14 2004 LibTIFF Buffer Overflows May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200412-02 ] PDFlib: Multiple overflows in the included TIFF library



--JP+T4n/bALQSJXh8
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200412-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PDFlib: Multiple overflows in the included TIFF library
      Date: December 05, 2004
      Bugs: #69043
        ID: 200412-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PDFlib is vulnerable to multiple overflows, which can potentially lead
to the execution of arbitrary code.

Background
==========

PDFlib is a library providing functions to handle PDF files. It
includes a modified TIFF library used to process TIFF images.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  media-libs/pdflib     < 5.0.4_p1                      >= 5.0.4_p1

Description
===========

The TIFF library is subject to several known vulnerabilities (see GLSA
200410-11). Most of these overflows also apply to PDFlib.

Impact
======

A remote attacker could entice a user or web application to process a
carefully crafted PDF file or TIFF image using a PDFlib-powered
program. This can potentially lead to the execution of arbitrary code
with the rights of the program processing the file.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PDFlib users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/pdflib-5.0.4_p1"

References
==========

  [ 1 ] PDFlib ChangeLog
        http://www.pdflib.com/products/pdflib/info/PDFlib-5.0.4p1-changes.txt
  [ 2 ] CAN-2004-0803
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0803
  [ 3 ] CAN-2004-0804
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0804
  [ 4 ] CAN-2004-0886
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0886
  [ 5 ] GLSA 200410-11
        http://www.gentoo.org/security/en/glsa/glsa-200410-11.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200412-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--JP+T4n/bALQSJXh8
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFBszcDRsm3eDkOu7kRAtTbAJ9WPV8tRoa4BVl2YQhF4cfglPbeIgCfWKt1
uFfNXz8tG8j/7i/X81CAEak=
=PWGU
-----END PGP SIGNATURE-----

--JP+T4n/bALQSJXh8--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC