SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   SquirrelMail Vendors:   SquirrelMail Development Team
(Gentoo Issues Fix) SquirrelMail Input Validation Hole in 'mime.php' Lets Remote Users Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1012247
SecurityTracker URL:  http://securitytracker.com/id/1012247
CVE Reference:   CVE-2004-1036   (Links to External Site)
Date:  Nov 17 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.4.3a and earlier; SquirrelMail 1.5.1-cvs before October 23, 2004
Description:   An input validation vulnerability was reported in SquirrelMail in 'mime.php'. A remote user can conduct cross-site scripting attacks.

The vendor reported that the software does not properly validate encoded text in certain headers. A remote user can create specially crafted e-mail that, when viewed by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the SquirrelMail software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The flaw resides in 'mime.php'.

The vendor credits Joost Pol with reporting this flaw.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the SquirrelMail software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   Gentoo has released a fix and indicates that all SquirrelMail users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.3a-r2"

Vendor URL:  www.squirrelmail.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Nov 10 2004 SquirrelMail Input Validation Hole in 'mime.php' Lets Remote Users Conduct Cross-Site Scripting Attacks



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200411-25 ] SquirrelMail: Encoded text XSS vulnerability


--nextPart1465694.ztpWT3TmS7
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200411-25
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: SquirrelMail: Encoded text XSS vulnerability
      Date: November 17, 2004
      Bugs: #70739
        ID: 200411-25

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Squirrelmail fails to properly sanitize user input, which could lead to
a compromise of webmail accounts.

Background
==========

SquirrelMail is a webmail package written in PHP. It supports IMAP and
SMTP, and can optionally be installed with SQL support.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /   Vulnerable   /           Unaffected
    -------------------------------------------------------------------
  1  mail-client/squirrelmail      < 1.4.3a-r2            >= 1.4.3a-r2

Description
===========

SquirrelMail fails to properly sanitize certain strings when decoding
specially-crafted headers.

Impact
======

By enticing a user to read a specially-crafted e-mail, an attacker can
execute arbitrary scripts running in the context of the victim's
browser. This could lead to a compromise of the user's webmail account,
cookie theft, etc.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All SquirrelMail users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.3a-r2"

Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

References
==========

  [ 1 ] SquirrelMail Advisory
        http://article.gmane.org/gmane.mail.squirrelmail.user/21169

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200411-25.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart1465694.ztpWT3TmS7
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBBmxeLzKC5hMHO6rkRAunlAJoCA6CyjdU6nB2Z9OaroSVCBgC6YACdEsHY
vkfdk41j7YrSt4bcwV4BgMc=
=V2yx
-----END PGP SIGNATURE-----

--nextPart1465694.ztpWT3TmS7--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC