SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   ez-ipupdate Vendors:   ez-ipupdate.com
(Mandrake Issues Fix) ez-ipupdate Format String Error in show_message() May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012176
SecurityTracker URL:  http://securitytracker.com/id/1012176
CVE Reference:   CVE-2004-0980   (Links to External Site)
Date:  Nov 11 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.0.11b7
Description:   A format string vulnerability was reported in ez-ipupdate. A remote user may be able to execute arbitrary code on the target system.

The flaw resides in the show_message() function, where user-supplied information is passed to a syslog() call without the proper format string specifier.

Ulf Harnhammar is credited with discovering this flaw.

Impact:   A remote user may be able to execute arbitrary code on the target system with the privilege of the ez-ipupdate daemon.
Solution:   Mandrake has released a fix.

Mandrakelinux 10.0:
43001a1c203324016ee52e13f332bcec 10.0/RPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.i586.rpm
a2fd96d510732b4c134b515f8ef13065 10.0/SRPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
d2e655466f2dbb7a08f340c01c19d283 amd64/10.0/RPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.amd64.rpm
a2fd96d510732b4c134b515f8ef13065 amd64/10.0/SRPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.src.rpm

Mandrakelinux 10.1:
3689b9d6ce9f69fd0d92c3f19c82839b 10.1/RPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.i586.rpm
74e0aecfeb792fa0aedd92e5ea54b46e 10.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
fb36525ea5a63c86c0ed20458c3ee6ca x86_64/10.1/RPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.x86_64.rpm
74e0aecfeb792fa0aedd92e5ea54b46e x86_64/10.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.src.rpm

Corporate Server 2.1:
8bcc14b5c24ffe8705380503b6dc2ded corporate/2.1/RPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.i586.rpm
9cea70e8fca7226629207d09f03caab5 corporate/2.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.src.rpm

Corporate Server 2.1/x86_64:
27986ecabaafeda17427e12d3e50a4e7 x86_64/corporate/2.1/RPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.x86_64.rpm
9cea70e8fca7226629207d09f03caab5 x86_64/corporate/2.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.src.rpm

Mandrakelinux 9.2:
ebb38de499a565b98d62d62dab339851 9.2/RPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.i586.rpm
e6277d246fe8548b28c37806fbcb5ef5 9.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.src.rpm

Mandrakelinux 9.2/AMD64:
ab50da51205a86e37c76416d7eb69b20 amd64/9.2/RPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.amd64.rpm
e6277d246fe8548b28c37806fbcb5ef5 amd64/9.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.src.rpm

Multi Network Firewall 8.2:
336e399432b254638fac691918e7e6f9 mnf8.2/RPMS/ez-ipupdate-3.0.11b8-2.1.M82mdk.i586.rpm
08de2bcdf128aa141b98b59faa412df9 mnf8.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.M82mdk.src.rpm

Vendor URL:  ez-ipupdate.com/ (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Mandriva/Mandrake)
Underlying OS Comments:  10.0, 10.1, 9.2, Corporate Server 2.1, Multi Network Firewall 8.2

Message History:   This archive entry is a follow-up to the message listed below.
Nov 11 2004 ez-ipupdate Format String Error in show_message() May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [Security Announce] MDKSA-2004:129 - Updated ez-ipupdate packages


This is a multi-part message in MIME format...

------------=_1100135007-1263-3796

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

                 Mandrakelinux Security Update Advisory
 _______________________________________________________________________

 Package name:           ez-ipupdate
 Advisory ID:            MDKSA-2004:129
 Date:                   November 10th, 2004

 Affected versions:	 10.0, 10.1, 9.2, Corporate Server 2.1,
			 Multi Network Firewall 8.2
 ______________________________________________________________________

 Problem Description:

 Ulf Harnhammar discovered a format string vulnerability in ez-ipupdate,
 a client for many dynamic DNS services.  The updated packages are
 patched to protect against this problem.
 _______________________________________________________________________

 References:

  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0980
 ______________________________________________________________________

 Updated Packages:
  
 Mandrakelinux 10.0:
 43001a1c203324016ee52e13f332bcec  10.0/RPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.i586.rpm
 a2fd96d510732b4c134b515f8ef13065  10.0/SRPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.src.rpm

 Mandrakelinux 10.0/AMD64:
 d2e655466f2dbb7a08f340c01c19d283  amd64/10.0/RPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.amd64.rpm
 a2fd96d510732b4c134b515f8ef13065  amd64/10.0/SRPMS/ez-ipupdate-3.0.11b8-2.1.100mdk.src.rpm

 Mandrakelinux 10.1:
 3689b9d6ce9f69fd0d92c3f19c82839b  10.1/RPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.i586.rpm
 74e0aecfeb792fa0aedd92e5ea54b46e  10.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.src.rpm

 Mandrakelinux 10.1/X86_64:
 fb36525ea5a63c86c0ed20458c3ee6ca  x86_64/10.1/RPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.x86_64.rpm
 74e0aecfeb792fa0aedd92e5ea54b46e  x86_64/10.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.101mdk.src.rpm

 Corporate Server 2.1:
 8bcc14b5c24ffe8705380503b6dc2ded  corporate/2.1/RPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.i586.rpm
 9cea70e8fca7226629207d09f03caab5  corporate/2.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.src.rpm

 Corporate Server 2.1/x86_64:
 27986ecabaafeda17427e12d3e50a4e7  x86_64/corporate/2.1/RPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.x86_64.rpm
 9cea70e8fca7226629207d09f03caab5  x86_64/corporate/2.1/SRPMS/ez-ipupdate-3.0.11b8-2.1.C21mdk.src.rpm

 Mandrakelinux 9.2:
 ebb38de499a565b98d62d62dab339851  9.2/RPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.i586.rpm
 e6277d246fe8548b28c37806fbcb5ef5  9.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.src.rpm

 Mandrakelinux 9.2/AMD64:
 ab50da51205a86e37c76416d7eb69b20  amd64/9.2/RPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.amd64.rpm
 e6277d246fe8548b28c37806fbcb5ef5  amd64/9.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.92mdk.src.rpm

 Multi Network Firewall 8.2:
 336e399432b254638fac691918e7e6f9  mnf8.2/RPMS/ez-ipupdate-3.0.11b8-2.1.M82mdk.i586.rpm
 08de2bcdf128aa141b98b59faa412df9  mnf8.2/SRPMS/ez-ipupdate-3.0.11b8-2.1.M82mdk.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrakeUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandrakesoft for security.  You can obtain
 the GPG public key of the Mandrakelinux Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandrakelinux at:

  http://www.mandrakesoft.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  <security linux-mandrake.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQFBkqlQmqjQ0CJFipgRAlrnAKC3WQM+gt84CvIzNbBNh5HKEVwMuACdFDj/
85DPoR3isrHpWcKPo9johTg=
=XlJ1
-----END PGP SIGNATURE-----


------------=_1100135007-1263-3796
Content-Type: text/plain; name="message.footer"
Content-Disposition: inline; filename="message.footer"
Content-Transfer-Encoding: 8bit

____________________________________________________
Want to buy your Pack or Services from MandrakeSoft? 
Go to http://www.mandrakestore.com
Join the Club : http://www.mandrakeclub.com
____________________________________________________

------------=_1100135007-1263-3796--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC