SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Speedtouch (USB Driver) Vendors:   speedtouch.sourceforge.net
(Gentoo Issues Fix) Speedtouch USB Driver Format String Flaw May Let Local Users Execute Arbitrary Code
SecurityTracker Alert ID:  1012045
SecurityTracker URL:  http://securitytracker.com/id/1012045
CVE Reference:   CVE-2004-0834   (Links to External Site)
Date:  Nov 2 2004
Impact:   Execution of arbitrary code via local system, Root access via local system, User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.3.1
Description:   A format string vulnerability was reported in the Speedtouch USB driver. A local user may be able to execute arbitrary code.

The vendor reported that the modem_run, pppoa2, and pppoa3 functions make an unsafe syslog() call. A local user may be able to invoke the driver to cause format string characters to be passed to syslog(), potentially resulting in arbitrary code execution. The code will run with the privileges of the driver, which may have set user id (setuid) privileges on some systems.

The vendor credits Max Vozeler with reporting this flaw.

Impact:   A local user may be able to execute arbitrary code, potentially with elevated privileges on some systems.
Solution:   Gentoo has released a fix and indicates that all Speedtouch USB driver users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/speedtouch-1.3.1"

Vendor URL:  speedtouch.sourceforge.net/index.php?/news.en.html (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Oct 20 2004 Speedtouch USB Driver Format String Flaw May Let Local Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200411-04 ] Speedtouch USB driver: Privilege escalation



--=-a+71IjEC+f9e0/BFbZHQ
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200411-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Speedtouch USB driver: Privilege escalation vulnerability
      Date: November 02, 2004
      Bugs: #68436
        ID: 200411-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability in the Speedtouch USB driver can be exploited to allow
local users to execute arbitrary code with escalated privileges.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The speedtouch package contains a driver for the ADSL SpeedTouch USB
modem.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package                /  Vulnerable  /                Unaffected
    -------------------------------------------------------------------
  1  net-dialup/speedtouch       < 1.3.1                      >=3D 1.3.1

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The Speedtouch USB driver contains multiple format string
vulnerabilities in modem_run, pppoa2 and pppoa3. This flaw is due to an
improperly made syslog() system call.

Impact
=3D=3D=3D=3D=3D=3D

A malicious local user could exploit this vulnerability by causing a
buffer overflow, and potentially allowing the execution of arbitrary
code with escalated privileges.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Speedtouch USB driver users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dnet-dialup/speedtouch-1.3.1"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CAN-2004-0834
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0834
  [ 2 ] Speedtouch Project News Announcements
        http://speedtouch.sourceforge.net/index.php?/news.en.html

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200411-04.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--=-a+71IjEC+f9e0/BFbZHQ
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBBh5fXRsm3eDkOu7kRAhvJAJ41E5ZgCc3GfE7RkL+Z38zv4/JmdQCeL0Q+
QYc4YLoPaV6OEEqcq7WmLEA=
=J9ru
-----END PGP SIGNATURE-----

--=-a+71IjEC+f9e0/BFbZHQ--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC