SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   MoniWiki Vendors:   moinmoin.wikiwikiweb.de
MoniWiki Input Validation Flaw Lets Remote Users Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1011912
SecurityTracker URL:  http://securitytracker.com/id/1011912
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Oct 25 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 1.0.8 and prior versions
Description:   Jeremy Bae at STG Security reported an input validation vulnerability in MoniWiki. A remote user can conduct cross-site scripting attacks.

It is reported that 'wiki.php' does not properly filter HTML code from user-supplied input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the MoniWiki software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

http://[target]/wiki.php/<script>alert("XSS Vulnerability exists")</script>

The vendor was notified on September 30, 2004.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the MoniWiki software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fixed version (1.0.9), available at:

http://kldp.net/project/showfiles.php?group_id=210&release_id=954

Vendor URL:  moniwiki.sf.net/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  STG Security Advisory: [SSA-20041022-08] MoniWiki XSS vulnerability


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

STG Security Advisory: [SSA-20041022-08] MoniWiki XSS vulnerability

Revision 1.0
Date Published: 2004-10-22 (KST)
Last Update: 2004-10-22
Disclosed by SSR Team (advisory@stgsecurity.com)

Summary
========
MoniWiki is a wiki web application used by many Korean Linux users.

It has a cross site scripting vulnerability.

Vulnerability Class
===================
Implementation Error: Input validation flaw

Details
=======
Due to an input validation flaw, the MoniWiki is vulnerable to cross site
scripting attacks.

http://[victim]/wiki.php/<script>alert("XSS Vulnerability exists")</script>

Impact
======
Medium: Malicious attackers can inject and execute arbitrary script code in
a user's browser session in context of an affected site.

Solution
=========
Update to MoniWiki 1.0.9

Affected Products
================
MoniWiki 1.0.8 and prior

Vendor Status: FIXED
=======================
2004-09-30 Vulnerability found.
2004-09-30 MoniWiki developer notified.
2004-10-21 MoniWiki 1.0.9 released.
2004-10-22 Official release.

Credits
======
Jeremy Bae at STG Security

-----BEGIN PGP SIGNATURE-----
Version: PGP 8.0

iQA/AwUBQXxdRT9dVHd/hpsuEQJeRACdFIt3UQJuAEqV52j30WIoX2HsRVUAoOf0
2xkoeV06zVCaShupwVhgNGxD
=Ns3M
-----END PGP SIGNATURE-----
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC