SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   WordPress Vendors:   wordpress.org
(Gentoo Issues Fix) WordPress Input Validation Hole Lets Remote Users Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1011696
SecurityTracker URL:  http://securitytracker.com/id/1011696
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Oct 15 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   An input validation vulnerability was reported in WordPress. A remote user can conduct cross-site scripting attacks.

It is reported that the software does not properly validate user-supplied input in the 'redirect_to' parameter of the 'wp-login.php' script. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the WordPress software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

A demonstration exploit URL is provided:

wp-login.php?redirect_to=[XSS]

In December 2004, Thomas Waldegger indicated that version 1.2.1 is also affected by this and other vulnerabilities.

Some demonstration exploit URLs are provided:

/wp-login.php?redirect_to=[XSS]
/wp-admin/bookmarklet.php?popupurl=[XSS]
/wp-admin/bookmarklet.php?content=[XSS]
/wp-admin/edit-comments.php?s=[XSS]
/wp-admin/edit-comments.php?s=bla&submit=Search&mode=[XSS]
/wp-admin/templates.php?file=[XSS]
/wp-admin/link-add.php?linkurl=[XSS]
/wp-admin/link-add.php?name=[XSS]
/wp-admin/link-categories.php?cat_id=[XSS]&action=Edit
/wp-admin/link-manager.php?order_by=[XSS]
/wp-admin/link-manager.php?cat_id=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_url=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_name=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_description=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_rel=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_image=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_rss_uri=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_notes=[XSS]
/wp-admin/link-manager.php?action=linkedit&link_id=[XSS]
/wp-admin/link-manager.php?action=linkedit&order_by=[XSS]
/wp-admin/link-manager.php?action=linkedit&cat_id=[XSS]
/wp-admin/post.php?content=[XSS]
/wp-admin/moderation.php?action=update&item_approved=[XSS]

It is also reported that a remote user may be able to inject SQL commands. Some demonstration exploit URLs are provided:

/index.php?m=bla
/wp-admin/edit.php?m=bla
/wp-admin/link-categories.php?cat_id=bla&action=Edit

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the WordPress software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   Gentoo has released a fix and indicates that all WordPress users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=www-apps/wordpress-1.2.1"
# emerge ">=www-apps/wordpress-1.2.1"

Vendor URL:  wordpress.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Sep 28 2004 WordPress Input Validation Hole Lets Remote Users Conduct Cross-Site Scripting Attacks



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200410-12 ] WordPress: HTTP response splitting and XSS



--=-k0hwKbesKEvG15WMqlgE
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200410-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: WordPress: HTTP response splitting and XSS vulnerabilities
      Date: October 14, 2004
      Bugs: #65798
        ID: 200410-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

WordPress contains HTTP response splitting and cross-site scripting
vulnerabilities.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

WordPress is a PHP and MySQL based content management and publishing
system.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/wordpress       < 1.2.1                         >=3D 1.2.1

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Due to the lack of input validation in the administration panel
scripts, WordPress is vulnerable to HTTP response splitting and
cross-site scripting attacks.

Impact
=3D=3D=3D=3D=3D=3D

A malicious user could inject arbitrary response data, leading to
content spoofing, web cache poisoning and other cross-site scripting or
HTTP response splitting attacks. This could result in compromising the
victim's data or browser.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All WordPress users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=3Dwww-apps/wordpress-1.2.1"
    # emerge ">=3Dwww-apps/wordpress-1.2.1"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] WordPress 1.2.1 Release Notes
        http://wordpress.org/development/2004/10/wp-121/

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200410-12.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--=-k0hwKbesKEvG15WMqlgE
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQBBbmr2Rsm3eDkOu7kRAlDOAJ9cM840cGmXsWdbzN2w/Xm8xe2BZQCdHYop
rJx71C14ZxyXZoYUnBvOuv8=
=7jwZ
-----END PGP SIGNATURE-----

--=-k0hwKbesKEvG15WMqlgE--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC