SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CUPS Vendors:   Easy Software Products
(Conectiva Issues Fix) CUPS Browsing Can Be Disabled By Remote Users
SecurityTracker Alert ID:  1011683
SecurityTracker URL:  http://securitytracker.com/id/1011683
CVE Reference:   CVE-2004-0558   (Links to External Site)
Date:  Oct 14 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in the Common UNIX Printing System (CUPS). A remote user can disable browsing.

Debian reported that a remote user can send a sepcially crafted UDP packet containing illegal URL characters to cupsd on port 631 to cause denial of service conditions.

The flaw resides in 'scheduler/dirsvc.c'.

Alvaro Martinez Echevarria is credited with discovering and patching the flaw.

Impact:   A remote user can disable CUPS browsing.
Solution:   Conectiva has released a fix.

ftp://atualizacoes.conectiva.com.br/10/SRPMS/cups-1.1.20-62425U10_4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-devel-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-devel-static-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-doc-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-foomatic-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-libs-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-netatalk-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-netware-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-ppd-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-serial-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/SRPMS/cups-1.1.18-29091U90_4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-devel-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-devel-static-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-doc-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-libs-1.1.18-29091U90_4cl.i386.rpm

Vendor URL:  www.cups.org/ (Links to External Site)
Cause:   Exception handling error, Input validation error
Underlying OS:  Linux (Conectiva)
Underlying OS Comments:  9, 10

Message History:   This archive entry is a follow-up to the message listed below.
Sep 15 2004 CUPS Browsing Can Be Disabled By Remote Users



 Source Message Contents

Subject:  [Conectiva-updates] [CLA-2004:872] Conectiva Security Announcement


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
CONECTIVA LINUX SECURITY ANNOUNCEMENT 
- --------------------------------------------------------------------------

PACKAGE   : cups
SUMMARY   : Fix for CUPS denial of service vulnerability
DATE      : 2004-10-14 11:12:00
ID        : CLA-2004:872
RELEVANT
RELEASES  : 9, 10

- -------------------------------------------------------------------------

DESCRIPTION
 CUPS[1] (Common UNIX Printing System) is an open-source, freely
 available and cross-platform printing solution for UNIX
 environments.
 
 Alvaro Martinez Echevarria found a vulnerability[2] in the CUPS
 Internet Printing Protocol (IPP) implementation that allows remote
 attackers to make CUPS stop listening on the IPP port by sending an
 empty UDP datagram packet to the IPP port, causing a denial of
 service situation.


SOLUTION
 It is recommended that all CUPS users upgrade to the latest packages.
 This update will automatically restart the service if it is already
 running.
 
 
 REFERENCES
 1.http://www.cups.org/
 2.http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0558


UPDATED PACKAGES
ftp://atualizacoes.conectiva.com.br/10/SRPMS/cups-1.1.20-62425U10_4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-devel-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-devel-static-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-doc-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-foomatic-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-libs-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-netatalk-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-netware-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-ppd-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/10/RPMS/cups-serial-1.1.20-62425U10_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/SRPMS/cups-1.1.18-29091U90_4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-devel-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-devel-static-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-doc-1.1.18-29091U90_4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/9/RPMS/cups-libs-1.1.18-29091U90_4cl.i386.rpm


ADDITIONAL INSTRUCTIONS
 The apt tool can be used to perform RPM packages upgrades:

 - run:                 apt-get update
 - after that, execute: apt-get upgrade

 Detailed instructions regarding the use of apt and upgrade examples 
 can be found at http://distro.conectiva.com.br/atualizacoes/#apt?idioma=en

- -------------------------------------------------------------------------
All packages are signed with Conectiva's GPG key. The key and instructions
on how to import it can be found at 
http://distro.conectiva.com.br/seguranca/chave/?idioma=en
Instructions on how to check the signatures of the RPM packages can be
found at http://distro.conectiva.com.br/seguranca/politica/?idioma=en

- -------------------------------------------------------------------------
All our advisories and generic update instructions can be viewed at
http://distro.conectiva.com.br/atualizacoes/?idioma=en

- -------------------------------------------------------------------------
Copyright (c) 2004 Conectiva Inc.
http://www.conectiva.com

- -------------------------------------------------------------------------
subscribe: conectiva-updates-subscribe@papaleguas.conectiva.com.br
unsubscribe: conectiva-updates-unsubscribe@papaleguas.conectiva.com.br
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQFBbntv42jd0JmAcZARAn8RAJ9HD4TopxMKjN8xMEm5QIVqSZkBDACeIP5G
sE0aiYNqpLhUJ3x/BKqaH5Q=
=Ko/e
-----END PGP SIGNATURE-----

______________________________________________________________________
subscribe: conectiva-updates-subscribe@papaleguas.conectiva.com.br
unsubscribe: conectiva-updates-unsubscribe@papaleguas.conectiva.com.br

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC