SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Security)  >   FreeRADIUS Vendors:   FreeRADIUS Server Project
(Gentoo Issues Fix) FreeRADIUS 'Ascend-Send-Secret' Processing Error Lets Remote Users Crash the Service
SecurityTracker Alert ID:  1011395
SecurityTracker URL:  http://securitytracker.com/id/1011395
CVE Reference:   CVE-2004-0938, CVE-2004-0960, CVE-2004-0961   (Links to External Site)
Updated:  Oct 19 2004
Original Entry Date:  Sep 23 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.0.0
Description:   A vulnerability was reported in FreeRADIUS. A remote user can cause the target RADIUS service to crash.

The VulnDisco RADIUS test suite includes tests for a previously unreported denial of service vulnerability in FreeRADIUS 1.0.0.

The vendor reported that Ascend-Send-Secret, like Tunnel-Password, requires an "original" packet to decode the attribute [CVE: ]. The software checks for Tunnel-Password, but not Ascend-Send-Secret.

The flaw resides in 'radius.c' and 'eap_tls.c'.

The vendor also reported that a remote user can supply malformed USR vendor-specific attributes to invoke a memcpy() operation with a '-1' argument, causing the RADIUS service to crash [CVE: CVE-2004-0960].

The vendor also reported that a remote user can send a series of Access-Request packets with Ascend-Send-Secret, Ascend-Recv-Secret, or Tunnel-Password attributes to cause the service to consume all available memory [CVE: CVE-2004-0961].

Impact:   A remote user can cause the RADIUS service to crash.
Solution:   Gentoo has released a fix and indicates that all FreeRADIUS users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=net-dialup/freeradius-1.0.1"
# emerge ">=net-dialup/freeradius-1.0.1"

Vendor URL:  www.freeradius.org/ (Links to External Site)
Cause:   Exception handling error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Sep 20 2004 FreeRADIUS 'Ascend-Send-Secret' Processing Error Lets Remote Users Crash the Service



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200409-29 ] FreeRADIUS: Multiple Denial of Service vulnerabilities


--nextPart5118737.bnvVOlXQ7F
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200409-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: FreeRADIUS: Multiple Denial of Service vulnerabilities
      Date: September 22, 2004
      Bugs: #60587
        ID: 200409-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple Denial of Service vulnerabilities were found and fixed in
FreeRADIUS.

Background
==========

FreeRADIUS is an open source RADIUS authentication server
implementation.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /  Vulnerable  /                Unaffected
    -------------------------------------------------------------------
  1  net-dialup/freeradius       < 1.0.1                      >= 1.0.1

Description
===========

There are undisclosed defects in the way FreeRADIUS handles incorrect
received packets.

Impact
======

A remote attacker could send specially-crafted packets to the
FreeRADIUS server to deny service to other users by crashing the
server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FreeRADIUS users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=net-dialup/freeradius-1.0.1"
    # emerge ">=net-dialup/freeradius-1.0.1"

References
==========

  [ 1 ] FreeRADIUS Vulnerability Notifications
        http://www.freeradius.org/security.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200409-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--nextPart5118737.bnvVOlXQ7F
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQBBUU61zKC5hMHO6rkRAuCIAJ4gRzQSNbghBrBHUfaxjXa3kM9uyQCfR/pa
Hc4vtzts9hsRcZBX74HsjxQ=
=Bc4/
-----END PGP SIGNATURE-----

--nextPart5118737.bnvVOlXQ7F--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC