SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   GTK+ Vendors:   gtk.org
(Gentoo Issues Fix for GTK+ 2) gdk-pixbug BMP, ICO, and XPM Image Processing Errors May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1011380
SecurityTracker URL:  http://securitytracker.com/id/1011380
CVE Reference:   CVE-2004-0753, CVE-2004-0782, CVE-2004-0783, CVE-2004-0788   (Links to External Site)
Date:  Sep 22 2004
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4.9-r1
Description:   Several vulnerabilities were reported in gdk-pixbug. A remote user can create a specially crafted image file that, when processed by an application using gdk-pixbug, will cause the application to crash or potentially execute arbitrary code. GTK+ 2 is also affected.

Mandrake and Red Hat reported that a remote user can create a specially crafted BMP image file that will cause gdk-pixbug to enter an infinite loop [CVE-2004-0753].

It is also reported that Chris Evans discovered several overflows. A heap-based overflow and a stack-based overflow reside in the xpm loader [CVE-2004-0782, CVE-2004-0783]. An integer overflow resides in the ico loader [CVE-2004-0788]. A remote user may be able to trigger the overflows to cause an application that uses gdk-pixbug to crash or possibly execute arbitrary code.

Impact:   A remote user may be able to cause an application using gdk-pixbug to crash or potentially execute arbitrary code with the privileges of the application.
Solution:   Gentoo has released a fix for GTK+ 2, which is affected by this vulnerability.

Gentoo indicates that all GTK+ 2 users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=x11-libs/gtk+-2.4.9-r1"
# emerge ">=x11-libs/gtk+-2.4.9-r1"

Gentoo indicates that all GdkPixbuf users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=media-libs/gdk-pixbuf-0.22.0-r3"
# emerge ">=media-libs/gdk-pixbuf-0.22.0-r3"

Vendor URL:  www.gtk.org/ (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Sep 15 2004 gdk-pixbug BMP, ICO, and XPM Image Processing Errors May Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200409-28 ] GTK+ 2, gdk-pixbuf: Multiple image decoding vulnerabilities


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200409-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GTK+ 2, gdk-pixbuf: Multiple image decoding vulnerabilities
      Date: September 21, 2004
      Bugs: #64230
        ID: 200409-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The GdkPixbuf library, which is also included in GTK+ 2, contains
several vulnerabilities that could lead to a Denial of Service or the
execution of arbitrary code.

Background
==========

GTK+ (GIMP Toolkit +) is a toolkit for creating graphical user
interfaces. The GdkPixbuf library provides facilities for image
handling. It is available as a standalone library as well as shipped
with GTK+ 2.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
  1  x11-libs/gtk+              < 2.4.9-r1                 >= 2.4.9-r1
                                                               < 2.0.0
  2  media-libs/gdk-pixbuf      < 0.22.0-r3               >= 0.22.0-r3
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

A vulnerability has been discovered in the BMP image preprocessor
(CAN-2004-0753). Furthermore, Chris Evans found a possible integer
overflow in the pixbuf_create_from_xpm() function, resulting in a heap
overflow (CAN-2004-0782). He also found a potential stack-based buffer
overflow in the xpm_extract_color() function (CAN-2004-0783). A
possible integer overflow has also been found in the ICO decoder.

Impact
======

With a specially crafted BMP image an attacker could cause an affected
application to enter an infinite loop when that image is being
processed. Also, by making use of specially crafted XPM or ICO images
an attacker could trigger the overflows, which potentially allows the
execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GTK+ 2 users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=x11-libs/gtk+-2.4.9-r1"
    # emerge ">=x11-libs/gtk+-2.4.9-r1"

All GdkPixbuf users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=media-libs/gdk-pixbuf-0.22.0-r3"
    # emerge ">=media-libs/gdk-pixbuf-0.22.0-r3"

References
==========

  [ 1 ] CAN-2004-0753
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0753
  [ 2 ] CAN-2004-0782
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0782
  [ 3 ] CAN-2004-0783
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0783
  [ 4 ] CAN-2004-0788
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0788
  [ 5 ] GNOME Bug 150601
        http://bugzilla.gnome.org/show_bug.cgi?id=150601

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200409-28.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFBUJRYvcL1obalX08RAgzmAKCQVANOb5xzqSuAkRvk37qnaiDW8wCfdl0i
XiGYgw/NB9bYGng5/0foFT0=
=eRg1
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC