SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   foomatic-filters Vendors:   linuxprinting.org
(Gentoo Issues Fix) Foomatic Bug in foomatic-rip Filter Lets Remote Users Execute Commands
SecurityTracker Alert ID:  1011372
SecurityTracker URL:  http://securitytracker.com/id/1011372
CVE Reference:   CVE-2004-0801   (Links to External Site)
Date:  Sep 21 2004
Impact:   Execution of arbitrary code via local system, Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 3.0.2
Description:   A vulnerability was reported in Foomatic in the foomatic-rip filter (part of foomatic-filters package). A remote or local user can execute commands on the target system.

The vendor reported that a remote or local user with access to CUPS can execute commands on the target system with 'lp' (or similar) user privileges.

Impact:   A remote or local user can execute commands with 'lp' user privileges.
Solution:   Gentoo has released a fix and indicates that all foomatic users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=net-print/foomatic-3.0.2"
# emerge ">=net-print/foomatic-3.0.2"

Gentoo notes that you should update foomatic, instead of foomatic-filters, to help ensure that all other foomatic components remain functional.

Vendor URL:  www.linuxprinting.org/pipermail/foomatic-devel/2004q3/001996.html (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Sep 15 2004 Foomatic Bug in foomatic-rip Filter Lets Remote Users Execute Commands



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200409-24 ] Foomatic: Arbitrary command execution in foomatic-rip filter



--qMm9M+Fa2AknHoGS
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200409-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Foomatic: Arbitrary command execution in foomatic-rip
            filter
      Date: September 20, 2004
      Bugs: #64166
        ID: 200409-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The foomatic-rip filter in foomatic-filters contains a vulnerability
which may allow arbitrary command execution on the print server.

Background
==========

Foomatic is a system for connecting printer drivers with spooler
systems such as CUPS and LPD. The foomatic-filters package contains
wrapper scripts which are designed to be used with Foomatic.

Affected packages
=================

    -------------------------------------------------------------------
     Package                     /  Vulnerable  /           Unaffected
    -------------------------------------------------------------------
  1  net-print/foomatic              <= 3.0.1                 >= 3.0.2
  2  net-print/foomatic-filters      <= 3.0.1                 >= 3.0.2
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

There is a vulnerability in the foomatic-filters package. This
vulnerability is due to insufficient checking of command-line
parameters and environment variables in the foomatic-rip filter.

Impact
======

This vulnerability may allow both local and remote attackers to execute
arbitrary commands on the print server with the permissions of the
spooler (oftentimes the "lp" user).

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All foomatic users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=net-print/foomatic-3.0.2"
    # emerge ">=net-print/foomatic-3.0.2"

PLEASE NOTE: You should update foomatic, instead of foomatic-filters.
This will help to ensure that all other foomatic components remain
functional.

References
==========

  [ 1 ] Foomatic Announcement
        http://www.linuxprinting.org/pipermail/foomatic-devel/2004q3/001996.html
  [ 2 ] Mandrakesoft Security Advisory
        http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:094
  [ 3 ] CAN 2004-0801
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0801

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200409-24.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--qMm9M+Fa2AknHoGS
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBTvCyaIxeYlQMsxsRAgmQAJ9D4bfN0nVfs/dw1u036IuqgTZ2NwCfaF6B
czrJtwXxsQCNGS16Q6F6K4o=
=mlh5
-----END PGP SIGNATURE-----

--qMm9M+Fa2AknHoGS--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC