SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   phpGroupWare Vendors:   phpGroupWare.org
(Gentoo Issues Fix) phpGroupWare Input Validation Error in Wiki Module Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1011341
SecurityTracker URL:  http://securitytracker.com/id/1011341
CVE Reference:   CVE-2004-0875   (Links to External Site)
Updated:  Sep 26 2004
Original Entry Date:  Sep 17 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 0.9.16.003
Description:   An input validation vulnerability was reported in phpGroupWare. A remote user can conduct cross-site scripting attacks.

The vendor reported that the wiki module does not properly validate user-supplied input before displaying the information. A remote user can create specially crafted input that, when viewed by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the phpGroupWare software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The flaw resides in 'transforms.php'.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the phpGroupWare software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   Gentoo has released a fix and indicates that all phpGroupWare users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=www-apps/phpgroupware-0.9.16.003"
# emerge ">=www-apps/phpgroupware-0.9.16.003"

Vendor URL:  phpgroupware.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Sep 17 2004 phpGroupWare Input Validation Error in Wiki Module Permits Cross-Site Scripting Attacks



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200409-22 ] phpGroupWare: XSS vulnerability in wiki module



--556+RJFJsNkpd1kp
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200409-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: phpGroupWare: XSS vulnerability in wiki module
      Date: September 16, 2004
      Bugs: #63063
        ID: 200409-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The phpGroupWare software contains a cross site scripting vulnerability
in the wiki module.

Background
==========

phpGroupWare is a web-based suite of group applications including
calendar, todo-list, addressbook, email, wiki, news headlines, and a
file manager.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
  1  www-apps/phpgroupware     < 0.9.16.003              >= 0.9.16.003

Description
===========

Due to an input validation error, the wiki module in the phpGroupWare
suite is vulnerable to cross site scripting attacks.

Impact
======

This vulnerability gives an attacker the ability to inject and execute
malicious script code, potentially compromising the victim's browser.

Workaround
==========

The is no known workaround at this time.

Resolution
==========

All phpGroupWare users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=www-apps/phpgroupware-0.9.16.003"
    # emerge ">=www-apps/phpgroupware-0.9.16.003"

References
==========

  [ 1 ] phpGroupWare ChangeLog
        http://downloads.phpgroupware.org/changelog
  [ 2 ] Secunia Advisory SA12466
        http://secunia.com/advisories/12466/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200409-22.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--556+RJFJsNkpd1kp
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBSgyNJPpRNiftIEYRAg0oAJ9uN669lde3AZhA6UKQYpISsY0ZfQCgmXV1
76zSmtRrc+xH187KXRrRh+E=
=s95X
-----END PGP SIGNATURE-----

--556+RJFJsNkpd1kp--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC