SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Forum/Board/Portal)  >   phpGroupWare Vendors:   phpGroupWare.org
phpGroupWare Input Validation Error in Wiki Module Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1011339
SecurityTracker URL:  http://securitytracker.com/id/1011339
CVE Reference:   CVE-2004-0875   (Links to External Site)
Updated:  Sep 26 2004
Original Entry Date:  Sep 17 2004
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 0.9.16.003
Description:   An input validation vulnerability was reported in phpGroupWare. A remote user can conduct cross-site scripting attacks.

The vendor reported that the wiki module does not properly validate user-supplied input before displaying the information. A remote user can create specially crafted input that, when viewed by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the phpGroupWare software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The flaw resides in 'transforms.php'.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the phpGroupWare software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has released a fixed version (0.9.16.003), available at:

http://download.phpgroupware.org/now

Vendor URL:  phpgroupware.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 17 2004 (Gentoo Issues Fix) phpGroupWare Input Validation Error in Wiki Module Permits Cross-Site Scripting Attacks
Gentoo has released a fix.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC