SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Oracle WebLogic Vendors:   BEA Systems
WebLogic Discloses System Version Information to Remote Users
SecurityTracker Alert ID:  1011231
SecurityTracker URL:  http://securitytracker.com/id/1011231
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Sep 14 2004
Impact:   Disclosure of system information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6.1 SP6, 7.0 SP5, and 8.1 SP3; and prior service packs
Description:   A vulnerability was reported in WebLogic Server and WebLogic Express. A remote user can determine system information.

BEA Systems reported that the system discloses server version information by default in response to HTTP and HTTPS requests.

Impact:   A remote user can determine system version information.
Solution:   The vendor has provided following solution information [quoted]:

* For WebLogic Server 8.1 perform the following steps:
1. Upgrade to WebLogic Server 8.1 Service Pack 3
2. Apply the patch ftp://ftpna.beasys.com/pub/releases/security/CR103309_810sp3.jar

Or Change the Send Server Header setting in deployed Web Servers to false. For more information, see:
http://e-docs.bea.com/wls/docs81/ConsoleHelp/domain_server_protocols_http.html

* For WebLogic Server 7.0 perform the following steps:
1. Upgrade to WebLogic Server 7.0 Service Pack 5 and
2. Apply the patch ftp://ftpna.beasys.com/pub/releases/security/CR103309_700sp5.jar

Or Change the Send Server Header setting in deployed Web Servers to false. For more information, see:
http://e-docs.bea.com/wls/docs70/ConsoleHelp/domain_server_connections_http.html

* For WebLogic Server 6.1 perform the following steps:
1. Upgrade to WebLogic Server 6.1 Service Pack 6
2. Apply the patch ftp://ftpna.beasys.com/pub/releases/security/CR103309_610sp6.jar

Or Change the Send Server Header setting in deployed Web Servers to false. For more information, see:
http://e-docs.bea.com/wls/docs61/security/lockdown.html

The fix will be included in WebLogic Server 6.1 Service Pack 7, WebLogic Server 7.0
Service Pack 6, and WebLogic Server 8.1 Service Pack 4.

Vendor URL:  dev2dev.bea.com/resourcelibrary/advisoriesnotifications/BEA04-70.00.jsp (Links to External Site)
Cause:   Access control error, Configuration error
Underlying OS:  Linux (Any), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), UNIX (Tru64), Windows (NT), Windows (2000)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC