SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Zlib Vendors:   GNU [multiple authors]
(Gentoo Issues Fix) Zlib Error Handling Bug in inflate() and inflateBack() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1011086
SecurityTracker URL:  http://securitytracker.com/id/1011086
CVE Reference:   CVE-2004-0797   (Links to External Site)
Date:  Aug 30 2004
Impact:   Denial of service via local system, Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.2 - 1.2.1
Description:   A vulnerability was reported in zlib. A remote user can cause denial of service conditions.

Johan Thelmen reported that a specially crafted file can cause a segmentation fault in zlib.

It is reported that the inflate() and inflateBack() functions do not properly handle errors.

Impact:   A user can create a file that when processed by zlib, will cause a segmentation fault. The specific impact depends on the application using zlib.
Solution:   Gentoo has released a fix and indicates that all zlib users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=sys-libs/zlib-1.2.1-r3"
# emerge ">=sys-libs/zlib-1.2.1-r3"

Gentoo also indicates that users should also run revdep-rebuild to rebuild any packages that depend on older versions of zlib :

# revdep-rebuild

Vendor URL:  www.gzip.org/zlib/ (Links to External Site)
Cause:   Exception handling error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Aug 30 2004 Zlib Error Handling Bug in inflate() and inflateBack() Lets Remote Users Deny Service



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200408-26 ] zlib: Denial of service vulnerability


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200408-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: zlib: Denial of service vulnerability
      Date: August 27, 2004
      Bugs: #61749
        ID: 200408-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The zlib library contains a Denial of Service vulnerability.

Background
==========

zlib is a general-purpose data-compression library.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  sys-libs/zlib      <= 1.2.1-r2                        >= 1.2.1-r3

Description
===========

zlib contains a bug in the handling of errors in the "inflate()" and
"inflateBack()" functions.

Impact
======

An attacker could exploit this vulnerability to launch a Denial of
Service attack on any application using the zlib library.

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of zlib.

Resolution
==========

All zlib users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=sys-libs/zlib-1.2.1-r3"
    # emerge ">=sys-libs/zlib-1.2.1-r3"

You should also run revdep-rebuild to rebuild any packages that depend
on older versions of zlib :

    # revdep-rebuild

References
==========

  [ 1 ] OpenPKG-SA-2004.038-zlib
        http://www.openpkg.org/security/OpenPKG-SA-2004.038-zlib.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200408-26.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBL4HwzKC5hMHO6rkRAh2AAJ9FErl2R7QrRcOuPCSfUojOsMIhKwCePwDq
Fi2c3A5pOl+YXWbZV0/om70=
=i0HL
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC