SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CVS Vendors:   GNU [multiple authors]
(NetBSD Issues Fix) CVS Entry Line Heap Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1010386
SecurityTracker URL:  http://securitytracker.com/id/1010386
CVE Reference:   CVE-2004-0396   (Links to External Site)
Date:  Jun 3 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.11.15 and prior versions (stable); 1.12.7 and prior versions (feature)
Description:   A heap overflow vulnerability was reported in Concurrent Versions System (CVS) in the processing of entry lines. A remote user can execute arbitrary code on the target system.

Stefan Esser of e-matters GmbH reported that the overflow occurs when an entry line is processed to determine if the modified and unchanged flags apply. A remote user can reportedly cause the flawed function to be called several times, inserting certain characters into the entry line and overwriting memory.

The vendor was reportedly notified on May 2, 2004.

The original advisory is available at:

http://security.e-matters.de/advisories/072004.html

Impact:   A remote user can execute arbitrary code on the target system with the privileges of the CVS server.
Solution:   The vendor has released a fix and provided the following fix instructions [quoted].

For NetBSD-current:

Systems running NetBSD-current dated from before 2004-05-21 should be upgraded to NetBSD-current dated 2004-05-22 or later.

The following directories need to be updated from the netbsd-current CVS branch (aka HEAD):
gnu/dist/cvs
gnu/usr.bin/cvs

To update from CVS, re-build, and re-install cvs:
# cd src
# cvs update -d -P gnu/dist/cvs gnu/usr.bin/cvs
# cd gnu/usr.bin/cvs

# make USETOOLS=no cleandir dependall
# make USETOOLS=no install


For NetBSD 1.6, 1.6.1, 1.6.2:

The binary distribution of NetBSD 1.6, 1.6.1 and 1.6.2 are vulnerable.

Systems running NetBSD 1.6 sources dated from before 2004-06-01 should be upgraded from NetBSD 1.6 sources dated 2004-06-02 or later.

Alternately, delete your cvs binaries, and update from pkgsrc.

NetBSD 1.6.3 will include the fix.

The following directories need to be updated from the netbsd-1-6 CVS branch:
gnu/dist/cvs
gnu/usr.bin/cvs

To update from CVS, re-build, and re-install cvs:

# cd src
# cvs update -d -P -r netbsd-1-6 gnu/dist/cvs gnu/usr.bin/cvs
# cd gnu/usr.bin/cvs

# make USETOOLS=no cleandir dependall
# make USETOOLS=no install

For pkgsrc:

If your system has devel/cvs pkgsrc version 1.11.15 or lower, update to 1.11.16

Vendor URL:  www.cvshome.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  UNIX (NetBSD)
Underlying OS Comments:  1.6, 1.6.1, 1.6.2

Message History:   This archive entry is a follow-up to the message listed below.
May 19 2004 CVS Entry Line Heap Overflow Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  NetBSD Security Advisory 2004-008: CVS server vulnerability



-----BEGIN PGP SIGNED MESSAGE-----


		 NetBSD Security Advisory 2004-008
		 =================================

Topic:		CVS server vulnerability

Version:	NetBSD-current:	source prior to May 21, 2004
		netBSD 1.6.2:	affected
		NetBSD 1.6.1:	affected
		NetBSD 1.6:	affected
		NetBSD-1.5.*:	not affected (does not ship with CVS)
		pkgsrc:		cvs packages prior to 1.11.16/1.12.8

Severity:	

Fixed:		NetBSD-current:		May 21, 2004
		NetBSD-2.0 branch:	May 21, 2004 (2.0 will include the fix)
		NetBSD-1.6 branch:	Jun 2, 2004 (1.6.3 will include the fix)
		pkgsrc:		cvs-1.11.16, 1.12.8 or higher corrects the issue


Abstract
========

CVS had heap overflow vulnerabilities which can be trigged remotely by
malicious people on the net.

NetBSD does not run a CVS server in the default install. Relatively few
users have reason to configure one, and only those who do are affected.


Technical Details
=================

http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0396


Solutions and Workarounds
=========================

If you run a CVS server:

We highly recommend you to upgrade your cvs binary to 1.11.16, or 1.12.8 or
higher.

The following instructions describe how to upgrade your cvs
binaries by updating your source tree and rebuilding and
installing a new version of cvs.

* NetBSD-current:

	Systems running NetBSD-current dated from before 2004-05-21
	should be upgraded to NetBSD-current dated 2004-05-22 or later.

	The following directories need to be updated from the
	netbsd-current CVS branch (aka HEAD):
		gnu/dist/cvs
		gnu/usr.bin/cvs

	To update from CVS, re-build, and re-install cvs:
		# cd src
		# cvs update -d -P gnu/dist/cvs gnu/usr.bin/cvs
		# cd gnu/usr.bin/cvs

		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install


* NetBSD 1.6, 1.6.1, 1.6.2:

	The binary distribution of NetBSD 1.6, 1.6.1 and 1.6.2 are vulnerable.

	Systems running NetBSD 1.6 sources dated from before
	2004-06-01 should be upgraded from NetBSD 1.6 sources dated
	2004-06-02 or later.

	Alternately, delete your cvs binaries, and update from pkgsrc.

	NetBSD 1.6.3 will include the fix.

	The following directories need to be updated from the
	netbsd-1-6 CVS branch:
		gnu/dist/cvs
		gnu/usr.bin/cvs

	To update from CVS, re-build, and re-install cvs:

		# cd src
		# cvs update -d -P -r netbsd-1-6 gnu/dist/cvs gnu/usr.bin/cvs
		# cd gnu/usr.bin/cvs

		# make USETOOLS=no cleandir dependall
		# make USETOOLS=no install

* pkgsrc:

        If your system has devel/cvs pkgsrc version 1.11.15 or lower, update
	to 1.11.16


Thanks To
=========

Matthias Scheler and Curt Sampson


Revision History
================

	2004-06-03	Initial release


More Information
================

Advisories may be updated as new information becomes available.
The most recent version of this advisory (PGP signed) can be found at 
  ftp://ftp.NetBSD.org/pub/NetBSD/security/advisories/NetBSD-SA2004-008.txt.asc

Information about NetBSD and NetBSD security can be found at
http://www.NetBSD.org/ and http://www.NetBSD.org/Security/.


Copyright 2004, The NetBSD Foundation, Inc.  All Rights Reserved.
Redistribution permitted only in full, unmodified form.

$NetBSD: NetBSD-SA2004-008.txt,v 1.3 2004/06/03 14:03:05 david Exp $

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (NetBSD)

iQCVAwUBQL8vqD5Ru2/4N2IFAQEY3wP/f3AiWgBr/9+bnHISOfulQ3/0/6sInB9+
DdXqWF7cvnysAbu+otEngIyzpnfiyulEmLPDkl6RFQ41LZgX6RdvCpxfqQrhhPEk
Ws7C5qXnJutEHpO5v77Eowf1biEiWyJMmR1Cip+bWJT2MqAMRL1cA4EYk1U46O89
JEpiD02Gbz0=
=JfC2
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC