SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   Midnight Commander Vendors:   GNU Midnight Commander Project
(Gentoo Issues Fix) Midnight Commander Has Multiple Bugs That May Let Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1010304
SecurityTracker URL:  http://securitytracker.com/id/1010304
CVE Reference:   CVE-2004-0226, CVE-2004-0231, CVE-2004-0232   (Links to External Site)
Date:  May 26 2004
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 4.6.0-r7
Description:   Several vulnerabilities were reported in Midnight Commander. A local user may be able to obtain elevated privileges.

Debian and Mandrake reported multiple vulnerabilities in Midnight Commander. The flaws include several buffer overflows [CVE: CVE-2004-0226], a format string vulnerability [CVE: CVE-2004-0232], and a temporary file and directory creation vulnerability [CVE: CVE-2004-0231].

Jacub Jelinek is credited with discovering the flaws.

Impact:   A local user may be able to gain the privileges of the user running mc.
Solution:   Gentoo has released a fix and indicates that all Midnight Commander users should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=app-misc/mc-4.6.0-r7
# emerge ">=app-misc/mc-4.6.0-r7"

Vendor URL:  www.ibiblio.org/mc/ (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error, State error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Apr 30 2004 Midnight Commander Has Multiple Bugs That May Let Local Users Gain Elevated Privileges



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200405-21 ] Midnight Commander: Multiple vulnerabilities



--bZ2MuwyI/0uB8yuJ
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Midnight Commander: Multiple vulnerabilities
      Date: May 26, 2004
      Bugs: #49990
        ID: 200405-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple security issues have been discovered in Midnight Commander
including several buffer overflows and string format vulnerabilities.

Background
==========

Midnight Commander is a visual console file manager.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /   Vulnerable   /                        Unaffected
    -------------------------------------------------------------------
  1  app-misc/mc      <= 4.6.0-r6                          >= 4.6.0-r7

Description
===========

Numerous security issues have been discovered in Midnight Commander,
including several buffer overflow vulnerabilities, multiple
vulnerabilities in the handling of temporary file and directory
creation, and multiple format string vulnerabilities.

Impact
======

The buffer overflows and format string vulnerabilites may allow
attackers to cause a denial of service or execute arbitrary code with
permissions of the user running MC. The insecure creation of temporary
files and directories could lead to a privilege escalation, including
root privileges, for a local attacker.

Workaround
==========

There is no known workaround at this time. All users are advised to
upgrade to version 4.6.0-r7 or higher of Midnight Commander.

Resolution
==========

All Midnight Commander users should upgrade to the latest stable
version:

    # emerge sync

    # emerge -pv ">=app-misc/mc-4.6.0-r7
    # emerge ">=app-misc/mc-4.6.0-r7"

References
==========

  [ 1 ] CAN-2004-0226
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0226
  [ 2 ] CAN-2004-0231
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0231
  [ 3 ] CAN-2004-0232
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0232

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200405-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--bZ2MuwyI/0uB8yuJ
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAtMZ5JPpRNiftIEYRAufgAJ4oXsCt1+32FSuW+0tbM0Ve+XoPHACeOeDx
8u/VID/8q71BPAdDtGr4K0s=
=ZFr8
-----END PGP SIGNATURE-----

--bZ2MuwyI/0uB8yuJ--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC