SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   CVS Vendors:   GNU [multiple authors]
(Gentoo Issues Fix) CVS Entry Line Heap Overflow Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1010240
SecurityTracker URL:  http://securitytracker.com/id/1010240
CVE Reference:   CVE-2004-0396   (Links to External Site)
Date:  May 20 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.11.15 and prior versions (stable); 1.12.7 and prior versions (feature)
Description:   A heap overflow vulnerability was reported in Concurrent Versions System (CVS) in the processing of entry lines. A remote user can execute arbitrary code on the target system.

Stefan Esser of e-matters GmbH reported that the overflow occurs when an entry line is processed to determine if the modified and unchanged flags apply. A remote user can reportedly cause the flawed function to be called several times, inserting certain characters into the entry line and overwriting memory.

The vendor was reportedly notified on May 2, 2004.

The original advisory is available at:

http://security.e-matters.de/advisories/072004.html

Impact:   A remote user can execute arbitrary code on the target system with the privileges of the CVS server.
Solution:   Gentoo has released a fix and indicates that all users running a CVS server should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=dev-util/cvs-1.11.16"
# emerge ">=dev-util/cvs-1.11.16"

Vendor URL:  www.cvshome.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
May 19 2004 CVS Entry Line Heap Overflow Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200405-12 ] CVS heap overflow vulnerability


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: CVS heap overflow vulnerability
      Date: May 20, 2004
      Bugs: #51460
        ID: 200405-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

CVS is subject to a heap overflow vulnerability allowing source
repository compromise.

Background
==========

CVS (Concurrent Versions System) is an open-source network-transparent
version control system. It contains both a client utility and a server.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /   Vulnerable   /                       Unaffected
    -------------------------------------------------------------------
  1  dev-util/cvs      <= 1.11.15                           >= 1.11.16

Description
===========

Stefan Esser discovered a heap overflow in the CVS server, which can be
triggered by sending malicious "Entry" lines and manipulating the flags
related to that Entry. This vulnerability was proven to be exploitable.

Impact
======

A remote attacker can execute arbitrary code on the CVS server, with
the rights of the CVS server. By default, Gentoo uses the "cvs" user to
run the CVS server. In particular, this flaw allows a complete
compromise of CVS source repositories. If you're not running a server,
then you are not vulnerable.

Workaround
==========

There is no known workaround at this time. All users are advised to
upgrade to the latest available version of CVS.

Resolution
==========

All users running a CVS server should upgrade to the latest stable
version:

    # emerge sync

    # emerge -pv ">=dev-util/cvs-1.11.16"
    # emerge ">=dev-util/cvs-1.11.16"

References
==========

  [ 1 ] E-matters advisory 07/2004
        http://security.e-matters.de/advisories/072004.html
  [ 2 ] CAN-2004-0396
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0396

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200405-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFArPYsvcL1obalX08RAra6AJ9y2fOFXOehlVb5V1VqX7ApBinrCQCglDIo
12HXNH7oaV2/olRemjT+Uq4=
=SFp9
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, SecurityGlobal.net LLC