SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (E-mail Server)  >   Exim Vendors:   Exim.org
(Gentoo Issues Fix) Exim Buffer Overflows in 'accept.c' and 'verify.c' Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1010194
SecurityTracker URL:  http://securitytracker.com/id/1010194
CVE Reference:   CVE-2004-0399, CVE-2004-0400   (Links to External Site)
Date:  May 18 2004
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.35, 4.32
Description:   Two buffer overflow vulnerabilities were reported in Exim. A remote user can execute arbitrary code on the target system.

Georgi Guninski reported that there is a flaw in 'accept.c' in exim 3.35 that can be triggered if the 'headers_check_syntax' option is configured in 'exim.conf'. A similar flaw in 'verify.c' in exim 4.32 can reportedly be triggered if the 'require verify = header_syntax' option is set [CVE: CVE-2004-0400]. Both of these flaws may be exploitable, but that was not confirmed, the report said.

It is also reported that version 3.35 contains a buffer overflow in 'verify.c' that can be exploited by a remote user if the 'exim.conf' file is configured with the 'sender_verify = true' option [CVE: CVE-2004-0399].

Some demonstration exploit scripts are provided in the original advisory.

The vendor is reportedly aware of the vulnerabilities.

The original advisory is available at:

http://www.guninski.com/exim1.html

Impact:   A remote user may be able to execute arbitary code on the target system with the privileges of the exim mail service.
Solution:   Gentoo has released a fix and indicates that all users of Exim should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=net-mail/exim-4.33-r1"
# emerge ">=net-mail/exim-4.33-r1"

Vendor URL:  www.exim.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
May 6 2004 Exim Buffer Overflows in 'accept.c' and 'verify.c' Let Remote Users Execute Arbitrary Code



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200405-07 ] Exim verify=header_syntax buffer overflow


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Exim verify=header_syntax buffer overflow
      Date: May 14, 2004
      Bugs: #50217
        ID: 200405-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

When the verify=header_syntax option is set, there is a buffer overflow
in Exim that allows remote execution of arbitrary code.

Background
==========

Exim is an highly configurable message transfer agent (MTA) developed
at the University of Cambridge.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  net-mail/exim        <= 4.33                           >= 4.33-r1

Description
===========

When the option "verify = header_syntax" is used in an ACL in the
configuration file, Exim is vulnerable to a buffer overflow attack that
can be triggered remotely by sending malicious headers in an email
message. Note that this option is not enabled in Exim's default
configuration file.

Impact
======

This vulnerability can be exploited to trigger a denial of service
attack and potentially execute arbitrary code with the rights of the
user used by the Exim daemon (by default this is the "mail" user in
Gentoo Linux).

Workaround
==========

Make sure the verify=header_syntax option is not used in your exim.conf
file.

Resolution
==========

All users of Exim should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=net-mail/exim-4.33-r1"
    # emerge ">=net-mail/exim-4.33-r1"

References
==========

  [ 1 ] CAN-2004-0400
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0400

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200405-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFApR4zvcL1obalX08RAj4qAKCImDLrj24oLDw0LWp9GjS3dxeHpQCglZvQ
fQIUyrGQF9T14nRKUWCceS4=
=T3cu
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2019, SecurityGlobal.net LLC