SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
(SCO Issues Fix for OpenUNIX) Apache 2.0 Web Server May Use a Weaker Encryption Implementation Than Specified in Some Cases
SecurityTracker Alert ID:  1010066
SecurityTracker URL:  http://securitytracker.com/id/1010066
CVE Reference:   CVE-2003-0192   (Links to External Site)
Date:  May 5 2004
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0 - 2.0.46
Description:   A vulnerability was reported in the Apache 2.0 web server. The server may apply a weakr encryption suite than intended.

It is reported that a local user can specify certain sequences of per-directory renegotiations and an SSLCipherSuite directive intended to upgrade from a weak encryption implementation to a stronger one. As a result, the system may use the weak ciphersuite.

Impact:   In a certain configuration, the system may use a weaker encryption implementation than specified.
Solution:   SCO has issued a fix.

UnixWare 7.1.3:

Location of Fixed Binaries

ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6


Verification

MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

Installing Fixed Binaries

Upgrade the affected binaries with the following sequence:

Download apache.pkg to the /var/spool/pkg directory

# pkgadd -d /var/spool/pkg/apache.pkg


Open UNIX 8.0.0:

First verify that openssl.097b-01.pkg has been installed.

Location of Fixed Binaries

ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6


Verification

MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

Installing Fixed Binaries

Upgrade the affected binaries with the following sequence:

Download apache.pkg to the /var/spool/pkg directory

# pkgadd -d /var/spool/pkg/apache.pkg


UnixWare 7.1.1:

First verify that openssl.097b-01.pkg has been installed.

Next verify that The latest UnixWare (UDK) Runtime Libraries are installed.

The UDK Runtime Libraries can be found at:

http://www.sco.com/download/

Select the SCO Product Downloads link then select latest UnixWare (UDK) Runtime Libraries which of this writting is currently 7.1.3.

Location of Fixed Binaries

ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6

Verification

MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

Installing Fixed Binaries

Upgrade the affected binaries with the following sequence:

Download apache.pkg to the /var/spool/pkg directory

# pkgadd -d /var/spool/pkg/apache.pkg

Vendor URL:  httpd.apache.org/ (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  UNIX (Open UNIX-SCO)
Underlying OS Comments:  UnixWare 7.1.1, 7.1.3; Open UNIX 8.0.0

Message History:   This archive entry is a follow-up to the message listed below.
Jul 9 2003 Apache 2.0 Web Server May Use a Weaker Encryption Implementation Than Specified in Some Cases



 Source Message Contents

Subject:  [Full-Disclosure] UnixWare 7.1.3 Open UNIX 8.0.0 UnixWare 7.1.1 : apache multiple vulnerabilities, upgraded to apache-1.3.29



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


______________________________________________________________________________

			SCO Security Advisory

Subject:		UnixWare 7.1.3 Open UNIX 8.0.0 UnixWare 7.1.1 : apache multiple vulnerabilities, upgraded to apache-1.3.29
Advisory number: 	SCOSA-2004.6
Issue date: 		2004 May 04
Cross reference:	sr886044 fz528423 erg712465 sr886995 fz528485 erg712487
______________________________________________________________________________


1. Problem Description

	The Common Vulnerabilities and Exposures project (cve.mitre.org)
	has assigned the following names to these issues.

	CAN-2003-0192: Apache 2 before 2.0.47, and certain versions
	of mod_ssl for Apache 1.3, do not properly handle "certain
	sequences of per-directory re-negotiations and the
	SSLCipherSuite directive being used to upgrade from a weak
	cipher suite to a strong one," which could cause Apache
	to use the weak cipher suite. 

	CAN-2003-0542: Multiple stack-based buffer overflows in 
	mod_alias and mod_rewrite for Apache before 1.3.29 may allow 
	attackers to create configuration files to cause a denial of 
	service or execute arbitrary code via a regular expression
	with more than 9 captures.


2. Vulnerable Supported Versions

	System				Binaries
	----------------------------------------------------------------------
	UnixWare 7.1.3 			Apache distribution
	Open UNIX 8.0.0 		Apache distribution
	UnixWare 7.1.1 			Apache distribution

3. Solution

	The proper solution is to install the latest packages.


4. UnixWare 7.1.3

	4.1 Location of Fixed Binaries

	ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6


	4.2 Verification

	MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

	md5 is available for download from
		ftp://ftp.sco.com/pub/security/tools


	4.3 Installing Fixed Binaries

	Upgrade the affected binaries with the following sequence:

	Download apache.pkg to the /var/spool/pkg directory

	# pkgadd -d /var/spool/pkg/apache.pkg


5. Open UNIX 8.0.0

	5.1 First verify that openssl.097b-01.pkg has been installed.

	5.2 Location of Fixed Binaries

	ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6


	5.3 Verification

	MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

	md5 is available for download from
		ftp://ftp.sco.com/pub/security/tools


	5.4 Installing Fixed Binaries

	Upgrade the affected binaries with the following sequence:

	Download apache.pkg to the /var/spool/pkg directory

	# pkgadd -d /var/spool/pkg/apache.pkg


6. UnixWare 7.1.1

	6.1 First verify that openssl.097b-01.pkg has been installed.

	6.2 Next verify that The latest UnixWare (UDK) Runtime 
	    Libraries are installed.  

	    The UDK Runtime Libraries can be found at 
	    http://www.sco.com/download/

	    Select the SCO Product Downloads link then
	    select latest UnixWare (UDK) Runtime Libraries
	    which of this writting is currently 7.1.3.

	6.3 Location of Fixed Binaries

	ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2004.6


	6.4 Verification

	MD5 (apache.pkg) = fad2ad4be6468d378b1509b5726ff2c7

	md5 is available for download from
		ftp://ftp.sco.com/pub/security/tools


	6.5 Installing Fixed Binaries

	Upgrade the affected binaries with the following sequence:

	Download apache.pkg to the /var/spool/pkg directory

	# pkgadd -d /var/spool/pkg/apache.pkg


7. References

	Specific references for this advisory:
		http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0192 
		http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0542

	SCO security resources:
		http://www.sco.com/support/security/index.html

	SCO security advisories via email
		http://www.sco.com/support/forums/security.html

	This security fix closes SCO incidents sr886044 fz528423
	erg712465 sr886995 fz528485 erg712487.


8. Disclaimer

	SCO is not responsible for the misuse of any of the information
	we provide on this website and/or through our security
	advisories. Our advisories are a service to our customers
	intended to promote secure installation and use of SCO
	products.

______________________________________________________________________________

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (SCO/UNIX_SVR5)

iD8DBQFAmDZNaqoBO7ipriERApF2AJ487+t+oerEoQbOR5BdYAqXAft1uQCfdYdp
vnBoCZ83g7k4Y5WrdbugAxg=
=Tu+q
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC