SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   Racoon Vendors:   KAME Project
(Gentoo Issues Fix for ipsec-tools and iputils) Racoon Can Be Crashed By Remote Users Sending Large ISAKMP Length Values
SecurityTracker Alert ID:  1009938
SecurityTracker URL:  http://securitytracker.com/id/1009938
CVE Reference:   CVE-2004-0403   (Links to External Site)
Date:  Apr 26 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 20040408a
Description:   A denial of service vulnerability was reported in Racoon. A remote user can cause Racoon to crash.

It is reported that a remote user can send a specially crafted ISAKMP header with a very large value in the length field to cause Racoon to attempt to allocate more memory than is available. As a result, the Racoon process may be terminated, the report said.

Impact:   A remote user can cause the Racoon daemon to crash.
Solution:   Gentoo has released a fix and indicates that ipsec-tools users should upgrade to version 0.2.5 or later:

# emerge sync

# emerge -pv ">=net-firewall/ipsec-tools-0.3.1"
# emerge ">=net-firewall/ipsec-tools-0.3.1"

iputils users should upgrade to version 021109-r3 or later:

# emerge sync

# emerge -pv ">=net-misc/iputils-021109-r3"
# emerge ">=net-misc/iputils-021109-r3"

Vendor URL:  www.kame.net/racoon/ (Links to External Site)
Cause:   Input validation error, Resource error
Underlying OS:  Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Apr 26 2004 Racoon Can Be Crashed By Remote Users Sending Large ISAKMP Length Values



 Source Message Contents

Subject:  [gentoo-announce] [ GLSA 200404-17 ] ipsec-tools and iputils contain a remote DoS vulnerability



--UnaWdueM1EBWVRzC
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200404-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal=20
     Title: ipsec-tools and iputils contain a remote DoS vulnerability

      Date: April 24, 2004
      Bugs: #48847
        ID: 200404-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

racoon, which is included in the ipsec-tools and iputils packages in
Portage, does not check the length of ISAKMP headers. Attackers may be
able to craft an ISAKMP header of sufficient length to consume all
available system resoources, causing a Denial of Service.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

=46rom http://ipsec-tools.sourceforge.net/ :

"IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec
implementation."

iputils is a collection of network monitoring tools, including racoon,
ping and ping6.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package                   /    Vulnerable    /         Unaffected
    -------------------------------------------------------------------
     net-firewall/ipsec-tools         < 0.3.1                 >=3D 0.3.1
     net-misc/iputils              =3D=3D 021109-r1           =3D=3D 021109=
-r3

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

When racoon receives an ISAKMP header, it allocates memory based on the
length of the header field. Thus, an attacker may be able to cause a
Denial of Services by creating a header that is large enough to consume
all available system resources.

Impact
=3D=3D=3D=3D=3D=3D

This vulnerability may allow an attacker to remotely cause a Denial of
Service.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

ipsec-tools users should upgrade to version 0.2.5 or later:

    # emerge sync

    # emerge -pv ">=3Dnet-firewall/ipsec-tools-0.3.1"
    # emerge ">=3Dnet-firewall/ipsec-tools-0.3.1"

iputils users should upgrade to version 021109-r3 or later:

    # emerge sync

    # emerge -pv ">=3Dnet-misc/iputils-021109-r3"
    # emerge ">=3Dnet-misc/iputils-021109-r3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0403

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200404-17.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

--UnaWdueM1EBWVRzC
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAihGdJPpRNiftIEYRAkoqAJ954f1JtHWL6TJUogGZ88ViVlXWMwCfQLSt
2hTbFQfV3IqoR35cfMq+E0c=
=PHgM
-----END PGP SIGNATURE-----

--UnaWdueM1EBWVRzC--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2020, SecurityGlobal.net LLC